[bug#33099] I add r-aspi package appended to cran.scm file

Message ID CAPNLzUOm9qLr5ctt_KkwiO6Gdr4Ld0DdpZ-+0O5jqKwY3Nm5=w@mail.gmail.com
State Accepted
Headers show
Series [bug#33099] I add r-aspi package appended to cran.scm file | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Laura Lazzati Oct. 21, 2018, 9:53 p.m. UTC
From 3628e4d7d4814777bb748c3f0ebba133814b2b94 Mon Sep 17 00:00:00 2001
From: laura <laura.lazzati.15@gmail.com>
Date: Sun, 21 Oct 2018 18:38:58 -0300
Subject: [PATCH] gnu: Add r-aspi

* gnu/packages/cran.scm (r-aspi): New variable
---
 gnu/packages/cran.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

+ asymmetry in parasitic infections.")
+    (license license:gpl3+)))

Comments

Gábor Boskovits Oct. 22, 2018, 8:46 a.m. UTC | #1
Hello Laura,

Almost there!

Laura Lazzati <laura.lazzati.15@gmail.com> ezt írta (időpont: 2018.
okt. 21., V, 23:54):
>
> From 3628e4d7d4814777bb748c3f0ebba133814b2b94 Mon Sep 17 00:00:00 2001
> From: laura <laura.lazzati.15@gmail.com>
> Date: Sun, 21 Oct 2018 18:38:58 -0300
> Subject: [PATCH] gnu: Add r-aspi
>
> * gnu/packages/cran.scm (r-aspi): New variable
> ---
>  gnu/packages/cran.scm | 21 +++++++++++++++++++++
>  1 file changed, 21 insertions(+)
>

Just a bit knitpicking, could you add the periods to the commit message, like:

gnu: Add r-aspi.

* gnu/packages/patches/cran.scm (r-aspi): New variable.


> diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
> index efcc2dccb..c219065e8 100644
> --- a/gnu/packages/cran.scm
> +++ b/gnu/packages/cran.scm
> @@ -6256,3 +6256,24 @@ a header row or not.  The dataset should
> contain only one independent variable
>  (x) and one dependent variable (y) and can contain a weight for each
>  observation.")
>      (license license:gpl2)))
> +
> +(define-public r-aspi
> +  (package
> +    (name "r-aspi")
> +    (version "0.2.0")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (cran-uri "aspi" version))
> +        (sha256
> +          (base32
> +            "0rhvxw243vvdv3hxa6pi343gcjc2cbxq1jzqirl9k1l4i3897l87"))))
> +    (build-system r-build-system)
> +    (home-page
> +      "http://cran.r-project.org/web/packages/aspi")
> +    (synopsis
> +      "Analysis of symmetry of parasitic infections")
> +    (description
> +      "This package provides tools for the analysis and visualization
> of bilateral
> + asymmetry in parasitic infections.")
> +    (license license:gpl3+)))
> --
> 2.17.1
>

This is fine now.

I still see these strange line breaks in the patch, how does that look on
you side?

Can you apply you own patches using git am?

You can send an updated patch with the corrected commit message,
or I can apply these minor changes and push it.
WDYT?

Best regards,
g_bor
Laura Lazzati Oct. 22, 2018, 12:58 p.m. UTC | #2
On Mon, 22 Oct 2018, 05:47 Gábor Boskovits, <boskovits@gmail.com> wrote:
>
> Hello Laura,
>
> Almost there!

Yes, after trying lots of things I figured out why it took me so long
to package it. The short story is that I did not understand that guix
import cran -r aspi was creating the template for me, I thought it
worked only for packages that were already packeged.I applied it to
another r package already available in guix, and modified it with
information about aspi from its website. The good side is that I
learned tons of guix commands.
>
>
> Laura Lazzati <laura.lazzati.15@gmail.com> ezt írta (időpont: 2018.
> okt. 21., V, 23:54):
> >
> > From 3628e4d7d4814777bb748c3f0ebba133814b2b94 Mon Sep 17 00:00:00 2001
> > From: laura <laura.lazzati.15@gmail.com>
> > Date: Sun, 21 Oct 2018 18:38:58 -0300
> > Subject: [PATCH] gnu: Add r-aspi
> >
> > * gnu/packages/cran.scm (r-aspi): New variable
> > ---
> >  gnu/packages/cran.scm | 21 +++++++++++++++++++++
> >  1 file changed, 21 insertions(+)
> >
>
> Just a bit knitpicking, could you add the periods to the commit message, like:
>
> gnu: Add r-aspi.
>
> * gnu/packages/patches/cran.scm (r-aspi): New variable.
>
>
> > diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
> > index efcc2dccb..c219065e8 100644
> > --- a/gnu/packages/cran.scm
> > +++ b/gnu/packages/cran.scm
> > @@ -6256,3 +6256,24 @@ a header row or not.  The dataset should
> > contain only one independent variable
> >  (x) and one dependent variable (y) and can contain a weight for each
> >  observation.")
> >      (license license:gpl2)))
> > +
> > +(define-public r-aspi
> > +  (package
> > +    (name "r-aspi")
> > +    (version "0.2.0")
> > +    (source
> > +      (origin
> > +        (method url-fetch)
> > +        (uri (cran-uri "aspi" version))
> > +        (sha256
> > +          (base32
> > +            "0rhvxw243vvdv3hxa6pi343gcjc2cbxq1jzqirl9k1l4i3897l87"))))
> > +    (build-system r-build-system)
> > +    (home-page
> > +      "http://cran.r-project.org/web/packages/aspi")
> > +    (synopsis
> > +      "Analysis of symmetry of parasitic infections")
> > +    (description
> > +      "This package provides tools for the analysis and visualization
> > of bilateral
> > + asymmetry in parasitic infections.")
> > +    (license license:gpl3+)))
> > --
> > 2.17.1
> >
>
> This is fine now.
>
> I still see these strange line breaks in the patch, how does that look on
> you side?

I guess the problem was that I was adding a line break because in the
previous patch when building I had a complain that that line was too
long. I have just told emacs to truncate long lines and buld the
package without problems. My fault. It was one of the two changes that
I made from the original definiton. Adding that break line and adding
licence: before gpl3+ because otherwhise  I got the error: Unbound
variable: gpl3+.
>
>
> Can you apply you own patches using git am?
In my local repo?
>
> You can send an updated patch with the corrected commit message,
> or I can apply these minor changes and push it.
> WDYT?
If it is not a problem for you, let me try :)
Do you mean by changing the subject of this chain of messages? Is that
OK for sending the patch with the corrections, but keeping the
debugs.gnu.org mail with the number as it is in the To field?
>
> Best regards,
> g_bor

Regards :)
Laura
Gábor Boskovits Oct. 22, 2018, 1:39 p.m. UTC | #3
Hi Laura,

Laura Lazzati <laura.lazzati.15@gmail.com> ezt írta (időpont: 2018.
okt. 22., H, 14:59):
>
> On Mon, 22 Oct 2018, 05:47 Gábor Boskovits, <boskovits@gmail.com> wrote:
> >
> > Hello Laura,
> >
> > Almost there!
>
> Yes, after trying lots of things I figured out why it took me so long
> to package it. The short story is that I did not understand that guix
> import cran -r aspi was creating the template for me, I thought it
> worked only for packages that were already packeged.I applied it to
> another r package already available in guix, and modified it with
> information about aspi from its website. The good side is that I
> learned tons of guix commands.
> >
> >
> > Laura Lazzati <laura.lazzati.15@gmail.com> ezt írta (időpont: 2018.
> > okt. 21., V, 23:54):
> > >
> > > From 3628e4d7d4814777bb748c3f0ebba133814b2b94 Mon Sep 17 00:00:00 2001
> > > From: laura <laura.lazzati.15@gmail.com>
> > > Date: Sun, 21 Oct 2018 18:38:58 -0300
> > > Subject: [PATCH] gnu: Add r-aspi
> > >
> > > * gnu/packages/cran.scm (r-aspi): New variable
> > > ---
> > >  gnu/packages/cran.scm | 21 +++++++++++++++++++++
> > >  1 file changed, 21 insertions(+)
> > >
> >
> > Just a bit knitpicking, could you add the periods to the commit message, like:
> >
> > gnu: Add r-aspi.
> >
> > * gnu/packages/patches/cran.scm (r-aspi): New variable.
> >
> >
> > > diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
> > > index efcc2dccb..c219065e8 100644
> > > --- a/gnu/packages/cran.scm
> > > +++ b/gnu/packages/cran.scm
> > > @@ -6256,3 +6256,24 @@ a header row or not.  The dataset should
> > > contain only one independent variable
> > >  (x) and one dependent variable (y) and can contain a weight for each
> > >  observation.")
> > >      (license license:gpl2)))
> > > +
> > > +(define-public r-aspi
> > > +  (package
> > > +    (name "r-aspi")
> > > +    (version "0.2.0")
> > > +    (source
> > > +      (origin
> > > +        (method url-fetch)
> > > +        (uri (cran-uri "aspi" version))
> > > +        (sha256
> > > +          (base32
> > > +            "0rhvxw243vvdv3hxa6pi343gcjc2cbxq1jzqirl9k1l4i3897l87"))))
> > > +    (build-system r-build-system)
> > > +    (home-page
> > > +      "http://cran.r-project.org/web/packages/aspi")
> > > +    (synopsis
> > > +      "Analysis of symmetry of parasitic infections")
> > > +    (description
> > > +      "This package provides tools for the analysis and visualization
> > > of bilateral
> > > + asymmetry in parasitic infections.")
> > > +    (license license:gpl3+)))
> > > --
> > > 2.17.1
> > >
> >
> > This is fine now.
> >
> > I still see these strange line breaks in the patch, how does that look on
> > you side?
>
> I guess the problem was that I was adding a line break because in the
> previous patch when building I had a complain that that line was too
> long. I have just told emacs to truncate long lines and buld the
> package without problems. My fault. It was one of the two changes that
> I made from the original definiton. Adding that break line and adding
> licence: before gpl3+ because otherwhise  I got the error: Unbound
> variable: gpl3+.
> >
> >
> > Can you apply you own patches using git am?
> In my local repo?
> >
> > You can send an updated patch with the corrected commit message,
> > or I can apply these minor changes and push it.
> > WDYT?
> If it is not a problem for you, let me try :)
> Do you mean by changing the subject of this chain of messages?

Yes, that would do half the job.

There is also a missing period in this line:
* gnu/packages/cran.scm (r-aspi): New variable

You can either fix these up manually, or using
git commit --amend, and fix these in the commit message.
That way git format-patch will fix these up.

> Is that
> OK for sending the patch with the corrections, but keeping the
> debugs.gnu.org mail with the number as it is in the To field?

Yes that is fine.

> >
> > Best regards,
> > g_bor
>
> Regards :)
> Laura

Best regards,
g_bor
Laura Lazzati Oct. 22, 2018, 10:29 p.m. UTC | #4
On Mon, Oct 22, 2018 at 10:39 AM Gábor Boskovits <boskovits@gmail.com> wrote:
>
> Hi Laura,
>
> Laura Lazzati <laura.lazzati.15@gmail.com> ezt írta (időpont: 2018.
> okt. 22., H, 14:59):
> >
> > On Mon, 22 Oct 2018, 05:47 Gábor Boskovits, <boskovits@gmail.com> wrote:
> > >
> > > Hello Laura,
> > >
> > > Almost there!
> >
> > Yes, after trying lots of things I figured out why it took me so long
> > to package it. The short story is that I did not understand that guix
> > import cran -r aspi was creating the template for me, I thought it
> > worked only for packages that were already packeged.I applied it to
> > another r package already available in guix, and modified it with
> > information about aspi from its website. The good side is that I
> > learned tons of guix commands.
> > >
> > >
> > > Laura Lazzati <laura.lazzati.15@gmail.com> ezt írta (időpont: 2018.
> > > okt. 21., V, 23:54):
> > > >
> > > > From 3628e4d7d4814777bb748c3f0ebba133814b2b94 Mon Sep 17 00:00:00 2001
> > > > From: laura <laura.lazzati.15@gmail.com>
> > > > Date: Sun, 21 Oct 2018 18:38:58 -0300
> > > > Subject: [PATCH] gnu: Add r-aspi
> > > >
> > > > * gnu/packages/cran.scm (r-aspi): New variable
> > > > ---
> > > >  gnu/packages/cran.scm | 21 +++++++++++++++++++++
> > > >  1 file changed, 21 insertions(+)
> > > >
> > >
> > > Just a bit knitpicking, could you add the periods to the commit message, like:
> > >
> > > gnu: Add r-aspi.
> > >
> > > * gnu/packages/patches/cran.scm (r-aspi): New variable.
> > >
> > >
> > > > diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
> > > > index efcc2dccb..c219065e8 100644
> > > > --- a/gnu/packages/cran.scm
> > > > +++ b/gnu/packages/cran.scm
> > > > @@ -6256,3 +6256,24 @@ a header row or not.  The dataset should
> > > > contain only one independent variable
> > > >  (x) and one dependent variable (y) and can contain a weight for each
> > > >  observation.")
> > > >      (license license:gpl2)))
> > > > +
> > > > +(define-public r-aspi
> > > > +  (package
> > > > +    (name "r-aspi")
> > > > +    (version "0.2.0")
> > > > +    (source
> > > > +      (origin
> > > > +        (method url-fetch)
> > > > +        (uri (cran-uri "aspi" version))
> > > > +        (sha256
> > > > +          (base32
> > > > +            "0rhvxw243vvdv3hxa6pi343gcjc2cbxq1jzqirl9k1l4i3897l87"))))
> > > > +    (build-system r-build-system)
> > > > +    (home-page
> > > > +      "http://cran.r-project.org/web/packages/aspi")
> > > > +    (synopsis
> > > > +      "Analysis of symmetry of parasitic infections")
> > > > +    (description
> > > > +      "This package provides tools for the analysis and visualization
> > > > of bilateral
> > > > + asymmetry in parasitic infections.")
> > > > +    (license license:gpl3+)))
> > > > --
> > > > 2.17.1
> > > >
> > >
> > > This is fine now.
> > >
> > > I still see these strange line breaks in the patch, how does that look on
> > > you side?
> >
> > I guess the problem was that I was adding a line break because in the
> > previous patch when building I had a complain that that line was too
> > long. I have just told emacs to truncate long lines and buld the
> > package without problems. My fault. It was one of the two changes that
> > I made from the original definiton. Adding that break line and adding
> > licence: before gpl3+ because otherwhise  I got the error: Unbound
> > variable: gpl3+.
> > >
> > >
> > > Can you apply you own patches using git am?
> > In my local repo?
> > >
> > > You can send an updated patch with the corrected commit message,
> > > or I can apply these minor changes and push it.
> > > WDYT?
I have already changed the commit messages.
I have generated several times the new patch, went back and so forth.
I can't figure out what is wrong.
I tried applying the different patches I went on generating with git
am <anyaspipatch>.patch
I tend to get this error: error: patch failed: gnu/packages/cran.scm:6256
And when I take a look at cran.scm, that line belongs to the previous
package (the one before appending mines)
I read in the coding style that lines must not exceed 80 columns, but
when I open cran.scm there are several packages that do so.
And if I don't add an eol in the description (is it there where you
see the line break?), after running lint command I get:
/home/laura/guix/gnu/packages/cran.scm:6261:2: r-aspi@0.2.0: line 6276
is way too long (119 characters)
Any ideas of how to help me fix this?
> > If it is not a problem for you, let me try :)
> > Do you mean by changing the subject of this chain of messages?
>
> Yes, that would do half the job.
>
> There is also a missing period in this line:
> * gnu/packages/cran.scm (r-aspi): New variable
>
> You can either fix these up manually, or using
> git commit --amend, and fix these in the commit message.
> That way git format-patch will fix these up.
>
> > Is that
> > OK for sending the patch with the corrections, but keeping the
> > debugs.gnu.org mail with the number as it is in the To field?
>
> Yes that is fine.
>
> > >
> > > Best regards,
> > > g_bor
> >
> > Regards :)
> > Laura
>
> Best regards,
> g_bor

Regards!
Laura
Ricardo Wurmus Oct. 23, 2018, 7:06 a.m. UTC | #5
Hi Laura,

> And if I don't add an eol in the description (is it there where you
> see the line break?), after running lint command I get:
> /home/laura/guix/gnu/packages/cran.scm:6261:2: r-aspi@0.2.0: line 6276
> is way too long (119 characters)

You should break the lines in your editor and then commit the changes
and format the patch.  The patch itself should not be modified.

Gábor’s question is about the patch itself, which appears to have a line
break in an unexpected place.  This may be a result of pasting it into
your email client.  It is probably better to attach the generated file
instead.

--
Ricardo
Gábor Boskovits Oct. 23, 2018, 7:39 a.m. UTC | #6
Hello Laura,

Ricardo Wurmus <ricardo.wurmus@mdc-berlin.de> ezt írta (időpont: 2018.
okt. 23., K, 9:06):
>
>
> Hi Laura,
>
> > And if I don't add an eol in the description (is it there where you
> > see the line break?), after running lint command I get:
> > /home/laura/guix/gnu/packages/cran.scm:6261:2: r-aspi@0.2.0: line 6276
> > is way too long (119 characters)
>
> You should break the lines in your editor and then commit the changes
> and format the patch.  The patch itself should not be modified.
>
> Gábor’s question is about the patch itself, which appears to have a line
> break in an unexpected place.  This may be a result of pasting it into
> your email client.  It is probably better to attach the generated file
> instead.
>

Yes, please, try to send the patch attached, I will be able to have a look
only tomorrow, because today is a national holiday in Hungary, and we
are expecting guests, but this contribution is in really good shape already.

> --
> Ricardo
g_bor

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index efcc2dccb..c219065e8 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6256,3 +6256,24 @@  a header row or not.  The dataset should
contain only one independent variable
 (x) and one dependent variable (y) and can contain a weight for each
 observation.")
     (license license:gpl2)))
+
+(define-public r-aspi
+  (package
+    (name "r-aspi")
+    (version "0.2.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "aspi" version))
+        (sha256
+          (base32
+            "0rhvxw243vvdv3hxa6pi343gcjc2cbxq1jzqirl9k1l4i3897l87"))))
+    (build-system r-build-system)
+    (home-page
+      "http://cran.r-project.org/web/packages/aspi")
+    (synopsis
+      "Analysis of symmetry of parasitic infections")
+    (description
+      "This package provides tools for the analysis and visualization
of bilateral