diff mbox series

[bug#53600] gnu: cppzmq: Update to 4.8.1.

Message ID 20220128100213.15263-1-simon@simonsouth.net
State Accepted
Headers show
Series [bug#53600] gnu: cppzmq: Update to 4.8.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon South Jan. 28, 2022, 10:02 a.m. UTC
* gnu/packages/networking.scm (cppzmq)[version]: Update to 4.8.1.
[arguments]: Update to run test suite except when cross-compiling.
[inputs]: Add catch2-framework.
---
Tested on x86-64: The package and its 13 dependents all build fine.

As before, on AArch64 the package itself builds fine, but unrelated build
failures are preventing me from checking all its dependents.

Note I've re-enabled the test suite (and added the Check2 framework as a
necessary input) as the issue mentioned in the "FIXME" appears to have been
resolved with upstream commit 197f8d2516.[1].

[0] https://issues.guix.gnu.org/53587
[1] https://github.com/zeromq/cppzmq/commit/197f8d251676fa3e18c9a8352b35f28b032600b1

 gnu/packages/networking.scm | 12 ++++--------
 1 file changed, 4 insertions(+), 8 deletions(-)


base-commit: e778910bdfc68c60a5be59aac93049d32feae904
prerequisite-patch-id: b2ac59f048d6061c443b4f0eefeee6a86d2f838a

Comments

Ludovic Courtès Feb. 4, 2022, 10:43 p.m. UTC | #1
Hi,

Simon South <simon@simonsouth.net> skribis:

> * gnu/packages/networking.scm (cppzmq)[version]: Update to 4.8.1.
> [arguments]: Update to run test suite except when cross-compiling.
> [inputs]: Add catch2-framework.
> ---
> Tested on x86-64: The package and its 13 dependents all build fine.
>
> As before, on AArch64 the package itself builds fine, but unrelated build
> failures are preventing me from checking all its dependents.
>
> Note I've re-enabled the test suite (and added the Check2 framework as a
> necessary input) as the issue mentioned in the "FIXME" appears to have been
> resolved with upstream commit 197f8d2516.[1].

Applied.

Thanks for doing extensive testing and for mentioning it, it really
helps!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 69e27f3113..a6b4786a06 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1152,7 +1152,7 @@  (define-public czmq
 (define-public cppzmq
   (package
     (name "cppzmq")
-    (version "4.6.0")
+    (version "4.8.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1160,19 +1160,15 @@  (define-public cppzmq
                     (commit (string-append "v" version))))
               (sha256
                (base32
-                "19acx2bzi4n6fdnfgkja1nds7m1bwg8lw5vfcijrx9fv75pa7m8h"))
+                "0zzq20wzk5grshxfqhqgqqfwb38w3k83r821isvyaxghsglpwks3"))
               (file-name (git-file-name name version))))
     (build-system cmake-build-system)
     (arguments
-     '(;; FIXME: The test suite requires downloading Catch and custom
-       ;; CMake targets, and refuses to use the system version.
-       ;; See <https://github.com/zeromq/cppzmq/issues/334>.
-       #:tests? #f
-       #:configure-flags '("-DCPPZMQ_BUILD_TESTS=OFF")))
+     `(#:tests? ,(not (%current-target-system)))) ; run unless cross-compiling
     (native-inputs
      (list pkg-config))
     (inputs
-     (list zeromq))
+     (list catch-framework2 zeromq))
     (home-page "https://zeromq.org")
     (synopsis "C++ bindings for the ØMQ messaging library")
     (description