diff mbox series

[bug#53444,1/3] gnu: Add python-i3ipc

Message ID 20220122114722.21774-1-paren@disroot.org
State Accepted
Headers show
Series [bug#53444,1/3] gnu: Add python-i3ipc | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( Jan. 22, 2022, 11:47 a.m. UTC
* gnu/packages/wm.scm(python-i3ipc): New variable.
---
 gnu/packages/wm.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Björn Höfling Sept. 25, 2022, 8:26 p.m. UTC | #1
On Sat, 22 Jan 2022 11:47:22 +0000
"\(unmatched-parenthesis via Guix-patches" via <guix-patches@gnu.org>
wrote:

> * gnu/packages/wm.scm(python-i3ipc): New variable.

I'm closing this ticket, as it has the same content as #56717, which
was already applied as commits

86da72fb5b3a35a30660e81084ed0c90ec5af08f
515288874ff12c00ca8d1d22a94ef4b4903fec76

Björn
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 67e113aaa2..975247bf07 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -49,6 +49,7 @@ 
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
 ;;; Copyright © 2021 Disseminate Dissent <disseminatedissent@protonmail.com>
 ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022 (unmatched parenthesis <paren@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -541,6 +542,25 @@  (define-public python-i3-py
 (define-public python2-i3-py
   (package-with-python2 python-i3-py))
 
+(define-public python-i3ipc
+  (package
+   (name "python-i3ipc")
+   (version "2.2.1")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (pypi-uri "i3ipc" version))
+     (sha256
+      (base32 "1s6crkdn7q8wmzl5d0pb6rdkhhbvp444yxilrgaylnbr2kbxg078"))))
+   (build-system python-build-system)
+   (arguments
+    ;; TODO: Fix tests
+    '(#:tests? #f))
+   (propagated-inputs (list python-xlib))
+   (home-page "https://github.com/altdesktop/i3ipc-python")
+   (synopsis "An improved Python library to control i3wm and sway")
+   (description "This package provides an improved Python library to control i3wm and sway.")
+   (license license:bsd-3)))
 (define-public qtile
   (package
     (name "qtile")