diff mbox series

[bug#53445,2/3] gnu: Add python2-i3ipc

Message ID 20220122114722.21774-2-paren@disroot.org
State Accepted
Headers show
Series [bug#53444,1/3] gnu: Add python-i3ipc | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( Jan. 22, 2022, 11:47 a.m. UTC
* gnu/packages/wm.scm(python2-i3ipc): New variable.
---
 gnu/packages/wm.scm | 3 +++
 1 file changed, 3 insertions(+)

Comments

M Jan. 22, 2022, 2:30 p.m. UTC | #1
(unmatched-parenthesis via Guix-patches via schreef op za 22-01-2022 om
11:47 [+0000]:
> * gnu/packages/wm.scm(python2-i3ipc): New variable.
> ---
>  gnu/packages/wm.scm | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 975247bf07..c791bcf44e 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -561,6 +561,9 @@ (define-public python-i3ipc
>     (synopsis "An improved Python library to control i3wm and sway")
>     (description "This package provides an improved Python library to control i3wm and sway.")
>     (license license:bsd-3)))
> +
> +(define-public python2-i3ipc
> +  (package-with-python2 python-i3ipc))

Python 2 has reached EOL since two years, can we avoid introducing new
python2 packages?  See, e.g.,
<https://mail.gnu.org/archive/html/guix-devel/2018-12/msg00545.html>.

Greetings,
Maxme.
Simon Tournier Jan. 24, 2022, 2:32 p.m. UTC | #2
Hi,

On Sat, 22 Jan 2022 at 13:23, (unmatched-parenthesis via Guix-patches
via <guix-patches@gnu.org> wrote:

> * gnu/packages/wm.scm(python2-i3ipc): New variable.

> +(define-public python2-i3ipc
> +  (package-with-python2 python-i3ipc))

As Maxime pointed, Python 2 is EOL since 2 years [1] and the current
work is to remove leaf Python 2 packages.  Therefore, I am proposing
to skip this 2/3 from the series and close this submission.

1: <https://www.python.org/doc/sunset-python-2/>


Cheers,
simon
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 975247bf07..c791bcf44e 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -561,6 +561,9 @@  (define-public python-i3ipc
    (synopsis "An improved Python library to control i3wm and sway")
    (description "This package provides an improved Python library to control i3wm and sway.")
    (license license:bsd-3)))
+
+(define-public python2-i3ipc
+  (package-with-python2 python-i3ipc))
 (define-public qtile
   (package
     (name "qtile")