diff mbox series

[bug#53179,v2,2/3] gnu: python-httpx: Update to 0.19.0.

Message ID 20220114210846.171922-2-monego@posteo.net
State Accepted
Headers show
Series [bug#53179,v2,1/3] gnu: python-httpcore: Update to 0.13.7. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Jan. 14, 2022, 9:08 p.m. UTC
* gnu/packages/python-web.scm (python-httpx): Update to 0.19.0.
[arguments]: Adjust skipped tests in the custom 'check phase.
[propagated-inputs]: Add python-async-generator,
python-charset-normalizer. Remove python-chardet.
---
 gnu/packages/python-web.scm | 24 +++++++++---------------
 1 file changed, 9 insertions(+), 15 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 639470d7d4..0a1d6d3d29 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5183,17 +5183,16 @@  Some things HTTP Core does do:
 (define-public python-httpx
   (package
     (name "python-httpx")
-    (version "0.16.1")
+    (version "0.19.0")
     (source
      (origin
-       ;; PyPI tarball does not contain tests.
-       (method git-fetch)
+       (method git-fetch)               ; no tests in PyPI
        (uri (git-reference
              (url "https://github.com/encode/httpx")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "00gmq45fckcqkj910bvd7pyqz1mvgsdvz4s0k7dzbnc5czzq1f4a"))))
+        (base32 "1w2wk6f07s6liyhsrq0qjj9vm2khp40kv85x91k70f1a8rwp2k3d"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -5201,16 +5200,10 @@  Some things HTTP Core does do:
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
-               (invoke "pytest" "-vv" "-k"
-                       ;; These tests try to open an outgoing connection.
+               (invoke "python" "-m" "pytest" "-k"
                        (string-append
-                        "not test_connect_timeout"
-                        " and not test_that_send_cause_async_client_to_be_not_"
-                        "closed"
-                        " and not test_that_async_client_caused_warning_when_"
-                        "being_deleted"
-                        " and not test_that_send_cause_client_to_be_not_closed"
-                        " and not test_async_proxy_close"
+                        ;; These tests open outgoing connections.
+                        "not test_async_proxy_close"
                         " and not test_sync_proxy_close"))))))))
     (native-inputs
      (list python-autoflake
@@ -5230,9 +5223,10 @@  Some things HTTP Core does do:
            python-trustme
            python-uvicorn))
     (propagated-inputs
-     (list python-brotli
+     (list python-async-generator
+           python-brotli
            python-certifi
-           python-chardet
+           python-charset-normalizer
            python-httpcore
            python-idna
            python-rfc3986