diff mbox series

[bug#53179,v2,1/3] gnu: python-httpcore: Update to 0.13.7.

Message ID 20220114210846.171922-1-monego@posteo.net
State Accepted
Headers show
Series [bug#53179,v2,1/3] gnu: python-httpcore: Update to 0.13.7. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Jan. 14, 2022, 9:08 p.m. UTC
* gnu/packages/python-web.scm (python-httpcore): Update to 0.13.7.
[native-inputs]: Order alphabetically.
[propagated-inputs]: Add python-anyio.
---
Fixed the copyright being added in the wrong file.

 gnu/packages/python-web.scm | 19 +++++++++----------
 1 file changed, 9 insertions(+), 10 deletions(-)


base-commit: 36f4745dc10e5d0e8b2a62cd2c8439629debae4f
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 708528983c..639470d7d4 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -37,7 +37,7 @@ 
 ;;; Copyright © 2020 Holger Peters <holger.peters@posteo.de>
 ;;; Copyright © 2020 Noisytoot <noisytoot@gmail.com>
 ;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
-;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2020 Konrad Hinsen <konrad.hinsen@fastmail.net>
 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
@@ -5124,20 +5124,19 @@  and serve updated contents upon changes to the directory.")
 (define-public python-httpcore
   (package
     (name "python-httpcore")
-    (version "0.12.2")
+    (version "0.13.7")
     (source
      (origin
-       ;; PyPI tarball does not contain tests.
-       (method git-fetch)
+       (method git-fetch)               ; no tests in PyPI
        (uri (git-reference
              (url "https://github.com/encode/httpcore")
-             (commit  version)))
+             (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1nrwwfdqjfc2a1k3j41cdwkprwvplf95fwmypdl2aq2qgp3209q0"))))
+        (base32 "1qf1kdscqs566qjzkxz9jxn0g30rx3s6jmxvizvc8q44m8rbs4gn"))))
     (build-system python-build-system)
     (arguments
-     `(#:tests? #f ; Tests hang at 98%
+     `(#:tests? #f                      ; Tests hang at 99%
        #:phases
        (modify-phases %standard-phases
          (replace 'check
@@ -5158,10 +5157,10 @@  and serve updated contents upon changes to the directory.")
            python-pytest-asyncio
            python-pytest-cov
            python-pytest-trio
-           python-uvicorn
-           python-trustme))
+           python-trustme
+           python-uvicorn))
     (propagated-inputs
-     (list python-h11 python-h2 python-sniffio python-trio
+     (list python-anyio python-h11 python-h2 python-sniffio python-trio
            python-trio-typing))
     (home-page "https://github.com/encode/httpcore")
     (synopsis "Minimal, low-level HTTP client")