diff mbox series

[bug#51630,2/2] gnu: python-orderedmultidict: Update to 1.0.1.

Message ID 20211106085802.5917-2-jgart@dismail.de
State Accepted
Headers show
Series [bug#51630,1/2] gnu: python-furl: Update to 2.1.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Nov. 6, 2021, 8:58 a.m. UTC
* gnu/packages/python-xyz.scm (python-orderedmultidict): Update to 1.0.1.
[native-inputs]: Add python-flake8.
---
 gnu/packages/python-xyz.scm | 10 ++++------
 1 file changed, 4 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8ba72170c0..74f07dc25c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6653,14 +6653,14 @@  (define-public python-multidict
 (define-public python-orderedmultidict
   (package
     (name "python-orderedmultidict")
-    (version "1.0")
+    (version "1.0.1")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "orderedmultidict" version))
         (sha256
           (base32
-            "1idjbl933avgaadscrjw1np3xkvnz3phq0l8vw5qs0rqcjx9b65q"))))
+            "1bc2v0yflsxjyyjx4q9wqx0j3bvzcw9z87d5pz4iqac7bsxhn1q4"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -6675,7 +6675,8 @@  (define-public python-orderedmultidict
     (propagated-inputs
      `(("python-six" ,python-six)))
     (native-inputs
-     `(("python-pycodestyle" ,python-pycodestyle)))
+     `(("python-flake8" ,python-flake8)
+       ("python-pycodestyle" ,python-pycodestyle)))
     (home-page "https://github.com/gruns/orderedmultidict")
     (synopsis "Python Ordered Multivalue Dictionary - omdict")
     (description "This package contains a library for ordered multivalue
@@ -6684,9 +6685,6 @@  (define-public python-orderedmultidict
 multivalue dictionary that retains the order of insertions and deletions.")
     (license license:unlicense)))
 
-(define-public python2-orderedmultidict
-  (package-with-python2 python-orderedmultidict))
-
 (define-public python-autopep8
   (package
     (name "python-autopep8")