diff mbox series

[bug#50505,07/12] gnu: Add python-pyrr.

Message ID 20210910112502.6466-7-daniel.meissner-i4k@ruhr-uni-bochum.de
State New
Headers show
Series gnu: Add python-manim | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Daniel Meißner Sept. 10, 2021, 11:24 a.m. UTC
* gnu/packages/python-xyz.scm (python-pyrr): New variable.
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Xinglu Chen Sept. 11, 2021, 7:58 p.m. UTC | #1
On Fri, Sep 10 2021, Daniel Meißner via Guix-patches via wrote:

> * gnu/packages/python-xyz.scm (python-pyrr): New variable.
> ---
>  gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 0102dbc4bb..eb0e67c98d 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -18977,6 +18977,31 @@ also written in C++ for high performance.")
>  types more concise to write. ")
>      (license license:bsd-3)))
>  
> +(define-public python-pyrr
> +  (package
> +    (name "python-pyrr")
> +    (version "0.10.3")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "pyrr" version))
> +       (sha256
> +        (base32
> +         "07byxkq8dcc8n6fc2q7g3vq3mxzzj0hqzm8hlq3gfwbf68h7n3rw"))))
> +    (build-system python-build-system)
> +    (propagated-inputs
> +     `(("python-multipledispatch" ,python-multipledispatch)
> +       ("python-numpy" ,python-numpy)))
> +    (home-page
> +     "https://github.com/adamlwgriffiths/Pyrr")

No need for a newline  :-)

> +    (synopsis
> +     "Mathematical functions for 3D graphics using NumPy")

Likewise.

> +    (description
> +     "A collection of object-oriented and procedural interfaces for working
> +with matrices, quaternions, vectors and plane/line/ray objects for 3D
> +graphics.")

The description should consist of one or more complete sentences, see
“16.4.4 Synopses and Descriptions” in the manual.  Maybe

  This Python package provides collection of object-oriented and
  procedural interfaces for working with matrices, quaternions, vectors
  and plane/line/ray objects for 3D graphics.

?
> +    (license license:bsd-3)))

The LICENSE file looks more like BSD-2.

> +
>  (define-public python-pyglet
>    (package
>      (name "python-pyglet")
> -- 
> 2.33.0
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0102dbc4bb..eb0e67c98d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18977,6 +18977,31 @@  also written in C++ for high performance.")
 types more concise to write. ")
     (license license:bsd-3)))
 
+(define-public python-pyrr
+  (package
+    (name "python-pyrr")
+    (version "0.10.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pyrr" version))
+       (sha256
+        (base32
+         "07byxkq8dcc8n6fc2q7g3vq3mxzzj0hqzm8hlq3gfwbf68h7n3rw"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-multipledispatch" ,python-multipledispatch)
+       ("python-numpy" ,python-numpy)))
+    (home-page
+     "https://github.com/adamlwgriffiths/Pyrr")
+    (synopsis
+     "Mathematical functions for 3D graphics using NumPy")
+    (description
+     "A collection of object-oriented and procedural interfaces for working
+with matrices, quaternions, vectors and plane/line/ray objects for 3D
+graphics.")
+    (license license:bsd-3)))
+
 (define-public python-pyglet
   (package
     (name "python-pyglet")