diff mbox series

[bug#50505,04/12] gnu: Add python-moderngl.

Message ID 20210910112502.6466-4-daniel.meissner-i4k@ruhr-uni-bochum.de
State New
Headers show
Series gnu: Add python-manim | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Daniel Meißner Sept. 10, 2021, 11:24 a.m. UTC
* gnu/packages/python-xyz.scm (python-moderngl): New variable.
---
 gnu/packages/python-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Xinglu Chen Sept. 11, 2021, 7:46 p.m. UTC | #1
On Fri, Sep 10 2021, Daniel Meißner via Guix-patches via wrote:

> * gnu/packages/python-xyz.scm (python-moderngl): New variable.
> ---
>  gnu/packages/python-xyz.scm | 27 +++++++++++++++++++++++++++
>  1 file changed, 27 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 251aad5b61..394f30226f 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -18930,6 +18930,33 @@ library.")
>  for ModernGL on multiple platforms.")
>     (license license:expat)))
>  
> +(define-public python-moderngl
> +  (package
> +    (name "python-moderngl")
> +    (version "5.6.4")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "moderngl" version))
> +       (sha256
> +        (base32
> +         "1ysinnyr3rkdisbihdrn1623l3rw45nx8p2j31dgffsykxah8vcc"))))
> +    (build-system python-build-system)
> +    (propagated-inputs
> +     `(("python-glcontext" ,python-glcontext)))
> +    (home-page
> +     "https://github.com/moderngl/moderngl")

Nit: no need for a newline  :-)

> +    (synopsis
> +     "Python wrapper for OpenGL")

Likewise.

> +    (description "ModernGL is a python wrapper over OpenGL 3.3+ core that
> +simplifies the creation of simple graphics applications like scientific
> +simulations, games or user interfaces.  Usually, acquiring in-depth knowledge
> +of OpenGL requires a steep learning curve.  In contrast, ModernGL is easy to
> +learn and use, moreover it is capable of rendering with high performance and
> +quality, with less code written.  The majority of the moderngl code base is
> +also written in C++ for high performance.")
> +    (license license:expat)))
> +
>  (define-public python-rencode
>    (package
>     (name "python-rencode")
> -- 
> 2.33.0
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 251aad5b61..394f30226f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18930,6 +18930,33 @@  library.")
 for ModernGL on multiple platforms.")
    (license license:expat)))
 
+(define-public python-moderngl
+  (package
+    (name "python-moderngl")
+    (version "5.6.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "moderngl" version))
+       (sha256
+        (base32
+         "1ysinnyr3rkdisbihdrn1623l3rw45nx8p2j31dgffsykxah8vcc"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-glcontext" ,python-glcontext)))
+    (home-page
+     "https://github.com/moderngl/moderngl")
+    (synopsis
+     "Python wrapper for OpenGL")
+    (description "ModernGL is a python wrapper over OpenGL 3.3+ core that
+simplifies the creation of simple graphics applications like scientific
+simulations, games or user interfaces.  Usually, acquiring in-depth knowledge
+of OpenGL requires a steep learning curve.  In contrast, ModernGL is easy to
+learn and use, moreover it is capable of rendering with high performance and
+quality, with less code written.  The majority of the moderngl code base is
+also written in C++ for high performance.")
+    (license license:expat)))
+
 (define-public python-rencode
   (package
    (name "python-rencode")