diff mbox series

[bug#50305] gnu: Add emacs-dictionary.

Message ID 20210831185257.7801-1-simon@simonsouth.net
State Accepted
Headers show
Series [bug#50305] gnu: Add emacs-dictionary. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Simon South Aug. 31, 2021, 6:52 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-dictionary): New variable.
---
 gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Arun Isaac Sept. 2, 2021, 8:39 p.m. UTC | #1
Hi Simon,

I pushed your patch to master after adding a copyright header. Thanks
for contributing to Guix! :-)

Regards,
Arun
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 222be589d7..bfdf4e12ef 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29360,6 +29360,27 @@  shorter than usual, using mostly unprefixed keys.")
 @acronym{CWL, Common Workflow Language} files.")
     (license license:gpl3+)))
 
+(define-public emacs-dictionary
+  (package
+    (name "emacs-dictionary")
+    (version "1.11")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/myrkr/dictionary-el")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0zsjbpq0s0xdxd9r541f04bj1khhgzhdlzr0m4p17zjh1zardbpi"))))
+    (build-system emacs-build-system)
+    (home-page "http://www.myrkr.in-berlin.de/dictionary/index.html")
+    (synopsis "Emacs client for dictionary servers")
+    (description "This package provides commands for interacting with a
+dictionary server (as defined by RFC 2229; by default, the public server at
+dict.org) from within Emacs.")
+    (license license:gpl2+)))
+
 (define-public emacs-multitran
   (package
     (name "emacs-multitran")