diff mbox series

[bug#50087,1/2] gn: Add go-github-com-oneofone-xxhash.

Message ID 20210817055042.35895-2-me@bonfacemunyoki.com
State Accepted
Headers show
Series Add csvdiff | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Munyoki Kilyungi Aug. 17, 2021, 5:50 a.m. UTC
* gnu/packages/golang.scm (go-github-com-oneofone-xxhash): New variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f4cd30c662..7cdd94b7f0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -29,6 +29,7 @@ 
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
 ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -8396,3 +8397,27 @@  zero round-trip encryption, and other advanced features.")
     (synopsis "Go compression library")
     (description "@code{compress} provides various compression algorithms.")
     (license license:bsd-3)))
+
+(define-public go-github-com-oneofone-xxhash
+  (package
+    (name "go-github-com-oneofone-xxhash")
+    (version "1.2.8")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/OneOfOne/xxhash")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0f98qk83l2fhpclvrgyxsa9b8m4pipf11fah85bnjl01wy4lvybw"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/OneOfOne/xxhash"))
+    (home-page "https://github.com/OneOfOne/xxhash")
+    (synopsis "Go implementation of xxhash")
+    (description "This is a native Go implementation of the
+@url{https://github.com/Cyan4973/xxHash, xxhash} algorithm, an extremely fast
+non-cryptographic Hash algorithm, working at speeds close to RAM limits.")
+    (license license:asl2.0)))