mbox series

[bug#50087,0/2] Add csvdiff

Message ID 20210817054743.35597-1-me@bonfacemunyoki.com
Headers show
Series Add csvdiff | expand

Message

Munyoki Kilyungi Aug. 17, 2021, 5:47 a.m. UTC
Hi all. This patch adds a fast csv diffing utility written in go-lang.

BonfaceKilz (2):
  gn: Add go-github-com-oneofone-xxhash.
  gn: Add go-github-com-aswinkarthik-csvdiff.

 gnu/packages/golang.scm | 58 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 58 insertions(+)

Comments

Munyoki Kilyungi Aug. 17, 2021, 5:50 a.m. UTC | #1
Hi all. This patch adds a fast csv diffing utility written in go-lang.

BonfaceKilz (2):
  gn: Add go-github-com-oneofone-xxhash.
  gn: Add go-github-com-aswinkarthik-csvdiff.

 gnu/packages/golang.scm | 58 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 58 insertions(+)
Arun Isaac Aug. 17, 2021, 8:31 a.m. UTC | #2
Hi Bonface,

Thanks for contributing to Guix! I pushed with the following few
changes.

1. I replaced "gn" with "gnu" in the commit message.
2. I improved the synopsis and description of both the packages.

Cheers! :-)
Arun
Jack Hill Aug. 17, 2021, 5:02 p.m. UTC | #3
On Tue, 17 Aug 2021, Arun Isaac wrote:

>
> Hi Bonface,
>
> Thanks for contributing to Guix! I pushed with the following few
> changes.
>
> 1. I replaced "gn" with "gnu" in the commit message.
> 2. I improved the synopsis and description of both the packages.
>
> Cheers! :-)
> Arun

Thanks to you both! I think I'll get a lot of use out of this package.

Best!
Jack
Sarah Morgensen Aug. 17, 2021, 8 p.m. UTC | #4
Hello,

On Tue, 17 Aug 2021, Arun Isaac wrote:

>
> Hi Bonface,
>
> Thanks for contributing to Guix! I pushed with the following few
> changes.
>
> 1. I replaced "gn" with "gnu" in the commit message.
> 2. I improved the synopsis and description of both the packages.
>
> Cheers! :-)
> Arun

Typically end-user Go packages will want inputs/native-inputs rather
than propagated inputs unless the input provides a binary used at
runtime, so user profiles are not cluttered (go-build-system needs
source from all transitive dependencies).  Also, a more friendly name
("csvdiff" is available) might be better for end-user packages like
this.

Apologies for not commenting sooner!

--
Sarah
Arun Isaac Aug. 18, 2021, 5:56 a.m. UTC | #5
Hi Sarah,

> Typically end-user Go packages will want inputs/native-inputs rather
> than propagated inputs unless the input provides a binary used at
> runtime, so user profiles are not cluttered (go-build-system needs
> source from all transitive dependencies).  Also, a more friendly name
> ("csvdiff" is available) might be better for end-user packages like
> this.

I agree. csvdiff being an end-user package, maybe we should also move it
to some file other than golang.scm.

@Bonface: Could you send patches to this effect?

Regards,
Arun
Munyoki Kilyungi Aug. 19, 2021, 7:23 a.m. UTC | #6
Arun Isaac <arunisaac@systemreboot.net> anaandika:

> Hi Sarah,
>
>> Typically end-user Go packages will want inputs/native-inputs rather
>> than propagated inputs unless the input provides a binary used at
>> runtime, so user profiles are not cluttered (go-build-system needs
>> source from all transitive dependencies).  Also, a more friendly name
>> ("csvdiff" is available) might be better for end-user packages like
>> this.
>
> I agree. csvdiff being an end-user package, maybe we should also move it
> to some file other than golang.scm.
>
> @Bonface: Could you send patches to this effect?
>
> Regards,
> Arun
>

Thanks for your feedback. Submitted patches in:
bug#50117
Arun Isaac Aug. 20, 2021, 10:30 a.m. UTC | #7
> Thanks to you both! I think I'll get a lot of use out of this package.

You're welcome! :-)