diff mbox series

[bug#49207,5/6] gnu: Add python-pyke.

Message ID 20210723232529.23745-6-monego@posteo.net
State New
Headers show
Series gnu: Add python-iris (scitools). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego July 23, 2021, 11:25 p.m. UTC
* gnu/packages/python-xyz.scm (python-pyke): New variable.
---
 gnu/packages/python-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 61b1b7d29c..360650332e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6009,6 +6009,39 @@  operators such as union, intersection, and difference.")
 search in Python.")
     (license license:lgpl3+)))
 
+(define-public python-pyke
+  (package
+    (name "python-pyke")
+    (version "1.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "scitools-pyke" version))
+       (sha256
+        (base32 "0q7nxd0gw135922ck155w2nj2vf47k7cgzdqipxlyrgq6q3lkinl"))))
+    (build-system python-build-system)
+    ;; FIXME: two tests are failing with:
+    ;; "AttributeError: 'fc_tests' object has no attribute 'engine'.".
+    (arguments
+     `(#:tests? #f))
+    (home-page "https://sourceforge.net/projects/pyke/")
+    (synopsis "Python Knowledge Engine")
+    (description "Pyke is a Python Knowledge Engine and automatic Python
+program generator.  Both forward-chaining and backward-chaining rules (which
+may include Python code) are compiled into Python.  It can also automatically
+assemble Python programs out of Python functions which are attached to
+backward-chaining rules.
+
+Features:
+
+@itemize
+@item Automatic programming: generates Python programs.
+@item Forward and backward chaining.
+@item Multiple knowledge engines and rule bases.
+@item Rule-based inheritance.
+@end itemize")
+    (license license:expat)))
+
 (define-public python-wurlitzer
   (package
     (name "python-wurlitzer")