diff mbox series

[bug#49207,2/6] gnu: Add python-xxhash.

Message ID 20210723232529.23745-3-monego@posteo.net
State New
Headers show
Series gnu: Add python-iris (scitools). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego July 23, 2021, 11:25 p.m. UTC
* gnu/packages/python-xyz.scm (python-xxhash): New variable.
---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index eef180b720..2b4ce0cba3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -136,6 +136,7 @@ 
   #:use-module (gnu packages crypto)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages dbm)
+  #:use-module (gnu packages digest)
   #:use-module (gnu packages djvu)
   #:use-module (gnu packages docker)
   #:use-module (gnu packages enchant)
@@ -13036,6 +13037,31 @@  fast xml and html manipulation.")
 @end itemize")
     (license license:bsd-2)))
 
+(define-public python-xxhash
+  (package
+    (name "python-xxhash")
+    (version "2.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "xxhash" version))
+       (sha256
+        (base32 "0jbvz19acznq00544gcsjg05fkvrmwbnwdfgrvwss3i1ys6avgmp"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'use-system-xxhash
+           (lambda _
+             (setenv "XXHASH_LINK_SO" "1"))))))
+    (inputs
+     `(("xxhash" ,xxhash)))
+    (home-page "https://github.com/ifduyue/python-xxhash")
+    (synopsis "Python binding for xxHash")
+    (description "This package provides a Python interface binding for the
+xxHash non-cryptographic hash algorithm.")
+    (license license:bsd-2)))
+
 (define-public python-anyjson
   (package
     (name "python-anyjson")