diff mbox series

[bug#49464,1/3] gnu: python-fido2: Update to 0.9.1.

Message ID 20210708112117.19368-1-contact@dhruvin.dev
State New
Headers show
Series Update yubikey-manager to version 4.0.3. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Dhruvin Gandhi July 8, 2021, 11:21 a.m. UTC
* gnu/packages/security-token.scm (python-fido2): Update to 0.9.1.
---
 gnu/packages/security-token.scm | 22 +++++++++++++++++-----
 1 file changed, 17 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index f8c9661df1..4c844bc46b 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -593,7 +593,7 @@  your existing infrastructure.")
 (define-public python-fido2
   (package
     (name "python-fido2")
-    (version "0.5.0")
+    (version "0.9.1")
     (source (origin
               (method url-fetch)
               (uri
@@ -602,10 +602,21 @@  your existing infrastructure.")
                 version "/fido2-" version ".tar.gz"))
               (sha256
                (base32
-                "1pl8d2pr6jzqj4y9qiaddhjgnl92kikjxy0bgzm2jshkzzic8mp3"))
+                "0vpyknka7wa4jl1xhvhli48wk70dih7hm45kdrchf8wf4cjyx046"))
+              (modules '((guix build utils)))
               (snippet
-               ;; Remove bundled dependency.
-               #~(delete-file "fido2/public_suffix_list.dat"))))
+               #~(begin
+                   ;; Remove bundled dependency.
+                   (delete-file "fido2/public_suffix_list.dat")
+                   ;; Upstream: To be deleted in the next release.
+                   (delete-file "fido2/nfc.py")
+                   ;; Remove unused platform code.
+                   (delete-file "fido2/hid/freebsd.py")
+                   (delete-file "fido2/hid/macos.py")
+                   (delete-file "fido2/hid/openbsd.py")
+                   (delete-file "fido2/hid/windows.py")
+                   ;; See https://bugs.python.org/issue16396.
+                   (delete-file "fido2/win_api.py")))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -621,7 +632,8 @@  your existing infrastructure.")
              #t)))))
     (propagated-inputs
      `(("python-cryptography" ,python-cryptography)
-       ("python-six" ,python-six)))
+       ("python-six" ,python-six)
+       ("python-pyscard" ,python-pyscard)))
     (native-inputs
      `(("python-mock" ,python-mock)
        ("python-pyfakefs" ,python-pyfakefs)