diff mbox series

[bug#49464,2/3] gnu: Add python-makefun.

Message ID 20210708112117.19368-2-contact@dhruvin.dev
State New
Headers show
Series Update yubikey-manager to version 4.0.3. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Dhruvin Gandhi July 8, 2021, 11:21 a.m. UTC
* gnu/packages/python-xyz.scm (python-makefun): New variable.
---
 gnu/packages/python-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f16bff460a..bec63743a7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12852,6 +12852,33 @@  python-xdo for newer bindings.)")
 (define-public python2-xdo
   (package-with-python2 python-xdo))
 
+(define-public python-makefun
+  (package
+    (name "python-makefun")
+    (version "1.11.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "makefun" version))
+       (sha256
+        (base32
+         "1378qarb4m3yvk2w36m8686nbf4bzk8kh6hnhk54z061w9jysgh3"))))
+    (build-system python-build-system)
+    (arguments
+     ;; Tests require too many packages, with circular dependencies.
+     '(#:tests? #f))
+    (native-inputs
+     `(("python-setuptools-scm" ,python-setuptools-scm)))
+    (home-page
+     "https://smarie.github.io/python-makefun/")
+    (synopsis
+     "Small library to dynamically create python functions")
+    (description
+     "makefun helps you create functions dynamically, with the signature of
+your choice.  It was largely inspired by decorator and functools, and created
+mainly to cover some of their limitations.")
+    (license license:bsd-3)))
+
 (define-public python-mako
   (package
     (name "python-mako")