diff mbox series

[bug#48729,v3,24/47] gnu: Add go-github-com-jezek-xgb.

Message ID 20210608232204.18111-24-rg@raghavgururajan.name
State Accepted
Headers show
Series None | expand

Commit Message

Raghav Gururajan June 8, 2021, 11:21 p.m. UTC
* gnu/packages/golang.scm (go-github-com-jezek-xgb): New variable.
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d541b696be..d06a617ebd 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -69,6 +69,32 @@ 
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1))
 
+(define-public go-github-com-jezek-xgb
+  (let ((commit "0e0f116e1240ae19099324c3b2632003082841b7")
+        (revision "155"))
+    (package
+      (name "go-github-com-jezek-xgb")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/jezek/xgb")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0zwy88ksh896i78h0k038s5fmg9bgxbphkiznqq5525137m6w7gz"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/jezek/xgb"))
+      (synopsis "X Go Binding")
+      (description "XGB is the X Go Binding, which is a low-level API to
+communicate with the core X protocol and many of the X extensions.  It is
+closely modeled after XCB and xpyb.")
+      (home-page "https://github.com/jezek/xgb")
+      (license license:bsd-3))))
+
 (define-public go-0xacab-org-leap-shapeshifter
   (let ((commit "0aa6226582efb8e563540ec1d3c5cfcd19200474")
         (revision "12"))