diff mbox series

[bug#48729,v3,26/47] gnu: Add go-github-com-getlantern-context.

Message ID 20210608232204.18111-26-rg@raghavgururajan.name
State Accepted
Headers show
Series None | expand

Commit Message

Raghav Gururajan June 8, 2021, 11:21 p.m. UTC
* gnu/packages/golang.scm (go-github-com-getlantern-context): New variable.
---
 gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9c182bba3c..7ccb085587 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -69,6 +69,34 @@ 
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1))
 
+(define-public go-github-com-getlantern-context
+  (let ((commit "c447772a6520c1a3ae6294a7df725ee08230f14e")
+        (revision "30"))
+    (package
+      (name "go-github-com-getlantern-context")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/getlantern/context")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "08s1m1pqkwppvvc6biccyxs7wqzmgjyhyqdgfzwm9vp0c6vzr2sg"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/getlantern/context"))
+      (native-inputs
+       `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)))
+      (synopsis "Goroutine-based Context State")
+      (description "This package provides a stack abstraction that allows nested
+contexts similar to jtolds' library, but using Enter() and Exit() instead of
+callback functions.")
+      (home-page "https://github.com/getlantern/context")
+      (license license:asl2.0))))
+
 (define-public go-github-com-burntsushi-xgbutil
   (let ((commit "ad855c7130460fb6cf40af9302c649a69082a4ee")
         (revision "335"))