diff mbox series

[bug#48850,v3] gnu: coreutils: Disable inotify-dir-recreate test

Message ID 20210608183814.3099881-1-contact@carldong.me
State Accepted
Headers show
Series [bug#48850,v3] gnu: coreutils: Disable inotify-dir-recreate test | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Carl Dong June 8, 2021, 6:38 p.m. UTC
Fixed my quoting thanks to mbakke :-)

---

This test fails on filesystems where tail detects that it cannot use
inotify safely. See https://issues.guix.gnu.org/47935 for more details.

* gnu/packages/base.scm (coreutils)[phases]: Disable
  inotify-dir-recreate tests, quote Hurd substitute* call to reduce
  rebuilds.
---
 gnu/packages/base.scm | 16 ++++++++++------
 1 file changed, 10 insertions(+), 6 deletions(-)

Comments

Ludovic Courtès June 11, 2021, 1:56 p.m. UTC | #1
Hi Carl,

Carl Dong <contact@carldong.me> skribis:

> Fixed my quoting thanks to mbakke :-)
>
> ---
>
> This test fails on filesystems where tail detects that it cannot use
> inotify safely. See https://issues.guix.gnu.org/47935 for more details.
>
> * gnu/packages/base.scm (coreutils)[phases]: Disable
>   inotify-dir-recreate tests, quote Hurd substitute* call to reduce
>   rebuilds.

LGTM and OK for ‘core-updates’, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index d30299a7b6..edc4c4a427 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -378,13 +378,17 @@  used to apply commands with arbitrarily long arguments.")
                        (("/bin/sh") (which "sh")))
                      (substitute* (find-files "tests" "\\.sh$")
                        (("#!/bin/sh") (string-append "#!" (which "sh"))))))
-                 ,@(if (hurd-target?)
-                       `((add-after 'unpack 'remove-tests
-                           (lambda _
-                             (substitute* "Makefile.in"
+                 (add-after 'unpack 'remove-tests
+                   (lambda _
+                     ,@(if (hurd-target?)
+                           '((substitute* "Makefile.in"
                                ;; this test hangs
-                               (("^ *tests/misc/timeout-group.sh.*") "")))))
-                       '()))))
+                               (("^ *tests/misc/timeout-group.sh.*") "")))
+                           '())
+                     (substitute* "Makefile.in"
+                       ;; fails on filesystems where inotify cannot be used,
+                       ;; more info in #47935
+                       (("^ *tests/tail-2/inotify-dir-recreate.sh.*") "")))))))
    (synopsis "Core GNU utilities (file, text, shell)")
    (description
     "GNU Coreutils package includes all of the basic command-line tools that