diff mbox series

[bug#48831,4/7] gnu: python-zeroconf: Update to 0.31.0.

Message ID 20210604114640.25535-5-mail@brendan.scot
State Accepted
Headers show
Series [bug#48831,1/7] gnu: calibre: Remove unused input python-dukpy. | expand

Commit Message

Brendan Tildesley June 4, 2021, 11:46 a.m. UTC
* gnu/packages/python-xyz.scm (python-zeroconf): Update to 0.31.0.
[native-inputs]: Add python-pytest.
[arguments]: Disable more networking tests that won't work in Guix.
---
 gnu/packages/python-xyz.scm | 11 +++++++----
 1 file changed, 7 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0c909b9a90..b036fe2904 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22030,17 +22030,18 @@  enumeration library in Python.")
 (define-public python-zeroconf
   (package
     (name "python-zeroconf")
-    (version "0.28.8")
+    (version "0.31.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "zeroconf" version))
        (sha256
         (base32
-         "0narq8haa3b375vfblbyil77n8bw0wxqnanl91pl0wwwm884mqjb"))))
+         "0i4qs6baj7mc468mr40hmy77sgfr7vhbrz7zs4dziikihhj818ak"))))
     (build-system python-build-system)
     (native-inputs
-     `(("python-nose" ,python-nose)))
+     `(("python-nose" ,python-nose)
+       ("python-pytest" ,python-pytest)))
     (propagated-inputs
      `(("python-ifaddr" ,python-ifaddr)))
     (arguments
@@ -22052,7 +22053,9 @@  enumeration library in Python.")
                      "--exclude" "test_integration_with_listener_ipv6"
                      "--exclude" "test_launch_and_close_v6_only"
                      "--exclude" "test_launch_and_close_v4_v6"
-                     "--exclude" "test_launch_and_close"))))))
+                     "--exclude" "test_launch_and_close"
+                     "--exclude" "test_close_multiple_times"
+                     "--exclude" "test_add_multicast_member_socket_errors"))))))
     (home-page "https://github.com/jstasiak/python-zeroconf")
     (synopsis "Pure Python mDNS service discovery")
     (description