diff mbox series

[bug#48831,2/7] gnu: Remove python-dukpy, python2-dukpy.

Message ID 20210604114640.25535-3-mail@brendan.scot
State Accepted
Headers show
Series [bug#48831,1/7] gnu: calibre: Remove unused input python-dukpy. | expand

Commit Message

Brendan Tildesley June 4, 2021, 11:46 a.m. UTC
* gnu/packages/python-xyz.scm: Remove unused packages python-dukpy,
python2-dukpy.
This is actually not the 'dukpy' package in pypi either but something
else made for calibre.
---
 gnu/packages/python-xyz.scm | 26 --------------------------
 1 file changed, 26 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b3ed73f04a..0c909b9a90 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18883,32 +18883,6 @@  executed more than a given number of times during a given period.")
 (define-public python2-ratelimiter
   (package-with-python2 python-ratelimiter))
 
-(define-public python-dukpy
-  (package
-    (name "python-dukpy")
-    (version "0.3")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/kovidgoyal/dukpy")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "13h21nqzasv4zj32xs61brmc106pr2cx243672crcmwxxnjgaxls"))))
-    (build-system python-build-system)
-    (home-page "https://github.com/kovidgoyal/dukpy")
-    (synopsis "Run JavaScript in python")
-    (description
-     "dukpy is a JavaScript runtime environment for Python using the duktape
-embeddable JavaScript engine.")
-    ;; Dukpy is licensed under MIT like the embedded duktape library,
-    ;; with 'errors.c' as GPL3.
-    (license (list license:expat license:gpl3))))
-
-(define-public python2-dukpy
-  (package-with-python2 python-dukpy))
-
 (define-public python-jsonrpclib-pelix
   (package
     (name "python-jsonrpclib-pelix")