diff mbox series

[bug#48465,08/35] gnu: lxqt-admin: Update to 0.17.0.

Message ID 20210516140620.1898-8-mail@brendan.scot
State Accepted
Headers show
Series None | expand

Commit Message

Brendan Tildesley May 16, 2021, 2:05 p.m. UTC
* gnu/packages/lxqt.scm (lxqt-admin): Update to 0.17.0.
[arguments]: Patch another Polkit file install path.
---
 gnu/packages/lxqt.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 4c905e7210..296381d3bc 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -316,14 +316,14 @@  LXQt and the system it's running on.")
 (define-public lxqt-admin
   (package
     (name "lxqt-admin")
-    (version "0.15.0")
+    (version "0.17.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
                            version "/" name "-" version ".tar.xz"))
        (sha256
-        (base32 "1zal37hyzqimwsymmi3w15n1iq78g53754s8abc9ylkzc236xpfc"))))
+        (base32 "07fkn3zmpfxjzzsv1hyv50sx0359n10lxjil35qn266nz165wj43"))))
     (build-system cmake-build-system)
     (inputs
      `(("kwindowsystem" ,kwindowsystem)
@@ -341,7 +341,8 @@  LXQt and the system it's running on.")
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-source
            (lambda _
-             (substitute* "lxqt-admin-user/CMakeLists.txt"
+             (substitute* '("lxqt-admin-user/CMakeLists.txt"
+                            "lxqt-admin-time/CMakeLists.txt")
                (("DESTINATION \"\\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
                 "DESTINATION \"share/polkit-1/actions"))
              #t))