diff mbox series

[bug#48465,33/35] gnu: lxqt-config: Move libkscreen to propagated-inputs.

Message ID 20210516140620.1898-33-mail@brendan.scot
State Accepted
Headers show
Series None | expand

Commit Message

Brendan Tildesley May 16, 2021, 2:06 p.m. UTC
* gnu/packages/lxqt.scm (lxqt-config): Move libkscreen to
propagated-inputs. Kscreen is a runtime dependency. lxqt-config-monitor
will not open without it available.
---
 gnu/packages/lxqt.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index c3b073ee13..f8d93faaef 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -375,7 +375,6 @@  the operating system LXQt is running on.")
     (inputs
      `(("eudev" ,eudev)
        ("kwindowsystem" ,kwindowsystem)
-       ("libkscreen" ,libkscreen)
        ("liblxqt" ,liblxqt)
        ("libqtxdg" ,libqtxdg)
        ("libxcursor" ,libxcursor)
@@ -391,6 +390,10 @@  the operating system LXQt is running on.")
      `(("pkg-config" ,pkg-config)
        ("lxqt-build-tools" ,lxqt-build-tools)
        ("qttools" ,qttools)))
+    ;; XXX: This is a workaround so libkscreen can find the backends as we
+    ;; dont have a way specify them. We may want to  patch like Nix does.
+    (propagated-inputs
+     `(("libkscreen" ,libkscreen)))
     (arguments
      '(#:tests? #f                      ; no tests
        #:phases