diff mbox series

[bug#47906,06/22] gnu: python-watchdog: Update to 1.0.2.

Message ID 20210420052246.470690-6-monego@posteo.net
State New
Headers show
Series Add Spyder | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego April 20, 2021, 5:22 a.m. UTC
* gnu/packages/python-xyz.scm (python-watchdog): Update to 1.0.2.
[arguments]: Enable all tests, pass "pytest" to #:test-target.
[native-inputs]: Add python-pytest, python-pytest-runner.
---
 gnu/packages/python-xyz.scm | 16 ++++++----------
 1 file changed, 6 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ae18466686..3e349d4bca 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22268,29 +22268,25 @@  files.  These files are used to translate strings in android apps.")
 (define-public python-watchdog
   (package
     (name "python-watchdog")
-    (version "0.9.0")
+    (version "1.0.2")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "watchdog" version))
         (sha256
          (base32
-          "07cnvvlpif7a6cg4rav39zq8fxa5pfqawchr46433pij0y6napwn"))))
+          "10l9r2nnk7gfh5asn4crvpa9kz83ng0zn5pzww7jnff06lmbqv1p"))))
     (build-system python-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'remove-failing
-           (lambda _
-             (delete-file "tests/test_inotify_buffer.py")
-             (delete-file "tests/test_snapshot_diff.py")
-             #t)))))
+     `(#:test-target "pytest"))
     (propagated-inputs
      `(("python-argh" ,python-argh)
        ("python-pathtools" ,python-pathtools)
        ("python-pyyaml" ,python-pyyaml)))
     (native-inputs
-     `(("python-pytest-cov" ,python-pytest-cov)
+     `(("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-runner" ,python-pytest-runner)
        ("python-pytest-timeout" ,python-pytest-timeout)))
     (home-page "https://github.com/gorakhargosh/watchdog")
     (synopsis "File system events monitoring")