diff mbox series

[bug#46288,3/4] gnu: Add r-sass.

Message ID 20210204011301.50868-3-kondor@librem.one
State Accepted
Headers show
Series [bug#46285,1/4] gnu: Add r-jquerylib. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Todor Kondić Feb. 4, 2021, 1:13 a.m. UTC
* gnu/packages/cran.scm(r-sass): Add variable.
---
 gnu/packages/cran.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

phodina Nov. 5, 2021, 8:24 a.m. UTC | #1
Hi,

this package has already been added in 281df0d225877bf784c562cbdec0400f7f4c4513 by Ricardo Wurmus.

Petr
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 89474a491d..e52963d789 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25832,3 +25832,34 @@  package directly.")
 either their total size or the age of the oldest object (or both),
 automatically pruning objects to maintain the constraints.")
     (license license:expat)))
+
+(define-public r-sass
+  (package
+    (name "r-sass")
+    (version "0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "sass" version))
+       (sha256
+        (base32
+         "1cxqwsdyz71mgflqqa65mfr161jlv8q9mshs1y19pxp6pz5wnv0s"))))
+    (properties `((upstream-name . "sass")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-digest" ,r-digest)
+       ("r-fs" ,r-fs)
+       ("r-htmltools" ,r-htmltools)
+       ("r-r6" ,r-r6)
+       ("r-rappdirs" ,r-rappdirs)
+       ("r-rlang" ,r-rlang)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/rstudio/sass")
+    (synopsis
+     "Syntactically Awesome Style Sheets")
+    (description
+     "An @code{SCSS} compiler, powered by the @code{LibSass} library.
+With this, R developers can use variables, inheritance, and functions
+to generate dynamic style sheets.  The package uses the @code{Sass
+CSS} extension language, which is stable and CSS compatible.")
+    (license license:expat)))