diff mbox series

[bug#46286,2/4] gnu: Add r-cachem.

Message ID 20210204011301.50868-2-kondor@librem.one
State Accepted
Headers show
Series [bug#46285,1/4] gnu: Add r-jquerylib. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Todor Kondić Feb. 4, 2021, 1:12 a.m. UTC
* gnu/packages/cran.scm(r-cachem): New variable.
---
 gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6f7d07140d..89474a491d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25808,3 +25808,27 @@  convenient way to perform nested resampling in combination with @code{mlr3}.")
 generated by @code{htmltools}.  Most R users do not need to use this
 package directly.")
     (license license:expat)))
+
+(define-public r-cachem
+  (package
+    (name "r-cachem")
+    (version "1.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "cachem" version))
+       (sha256
+        (base32
+         "0hann47kpalhi0wp86xkd3j6zbl6x785ciggl86z53znyk1ywx44"))))
+    (properties `((upstream-name . "cachem")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-fastmap" ,r-fastmap) ("r-rlang" ,r-rlang)))
+    (home-page "https://cachem.r-lib.org/")
+    (synopsis
+     "Cache R Objects with Automatic Pruning")
+    (description
+     "Key-value stores with automatic pruning.  Caches can limit
+either their total size or the age of the oldest object (or both),
+automatically pruning objects to maintain the constraints.")
+    (license license:expat)))