diff mbox series

[bug#45641,4/6] gnu: Add ruby-typhoeus.

Message ID 20210104003215.8932-4-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#45641,1/6] gnu: Add ruby-yell. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Giacomo Leidi Jan. 4, 2021, 12:32 a.m. UTC
* gnu/packages/ruby.scm (ruby-typhoeus): New variable.
---
 gnu/packages/ruby.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 06d4637df4..4999b95c04 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -11835,3 +11835,27 @@  is a gigantic eagle.  So much for the history.  In the modern world, Ethon
 is a very basic @code{libcurl} wrapper using ffi.")
     (home-page "https://github.com/typhoeus/ethon")
     (license license:expat)))
+
+(define-public ruby-typhoeus
+  (package
+    (name "ruby-typhoeus")
+    (version "1.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "typhoeus" version))
+       (sha256
+        (base32
+         "1m22yrkmbj81rzhlny81j427qdvz57yk5wbcf3km0nf3bl6qiygz"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:tests? #f))                    ;there are none
+    (propagated-inputs `(("ruby-ethon" ,ruby-ethon)))
+    (synopsis
+     "Typhoeus wraps @code{libcurl} in order to make fast and reliable requests ")
+    (description
+     "Like a modern code version of the mythical beast with 100 serpent heads, Typhoeus
+runs HTTP requests in parallel while cleanly encapsulating handling logic.")
+    (home-page
+     "https://github.com/typhoeus/typhoeus")
+    (license license:expat)))