diff mbox series

[bug#45641,3/6] gnu: Add ruby-ethon.

Message ID 20210104003215.8932-3-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#45641,1/6] gnu: Add ruby-yell. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Giacomo Leidi Jan. 4, 2021, 12:32 a.m. UTC
* gnu/packages/ruby.scm (ruby-ethon): New variable.
---
 gnu/packages/ruby.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d9ff47bf03..06d4637df4 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -11812,3 +11812,26 @@  instead tries to provide a sane API while taking advantage of @code{libcurl}
 under the hood.")
     (home-page "https://github.com/toland/patron")
     (license license:expat)))
+
+(define-public ruby-ethon
+  (package
+    (name "ruby-ethon")
+    (version "0.12.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "ethon" version))
+       (sha256
+        (base32
+         "0gggrgkcq839mamx7a8jbnp2h7x2ykfn34ixwskwb0lzx2ak17g9"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:tests? #f))                    ;there are none
+    (inputs `(("curl" ,curl)))
+    (propagated-inputs `(("ruby-ffi" ,ruby-ffi)))
+    (synopsis "Very lightweight @code{libcurl} wrapper")
+    (description "In Greek mythology, Ethon, the son of Typhoeus and Echidna,
+is a gigantic eagle.  So much for the history.  In the modern world, Ethon
+is a very basic @code{libcurl} wrapper using ffi.")
+    (home-page "https://github.com/typhoeus/ethon")
+    (license license:expat)))