diff mbox series

[bug#45641,1/6] gnu: Add ruby-yell.

Message ID 20210104003215.8932-1-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#45641,1/6] gnu: Add ruby-yell. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Giacomo Leidi Jan. 4, 2021, 12:32 a.m. UTC
* gnu/packages/ruby.scm (ruby-yell): New variable.
---
 gnu/packages/ruby.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index c5b1af79d3..f1194c4c3d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -11758,3 +11758,30 @@  defined in @file{.travis.yml} on your local machine, using @code{rvm},
 you the speed and portability of libgit2 with the beauty of the Ruby
 language.")
     (license license:expat)))
+
+(define-public ruby-yell
+  (package
+    (name "ruby-yell")
+    (version "2.2.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (rubygems-uri "yell" version))
+        (sha256
+          (base32
+            "1g16kcdhdfvczn7x81jiq6afg3bdxmb73skqjyjlkp5nqcy6y5hx"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "rake" "examples")))))) ; there is no test target.
+    (synopsis
+      "Yell - Your Extensible Logging Library")
+    (description
+      "Yell  is a comprehensive logging replacement for Ruby.  It defines
+multiple adapters, various log level combinations and message formatting
+options.")
+    (home-page "https://github.com/rudionrails/yell")
+    (license license:expat)))