diff mbox series

[bug#44990,v3,4/8] gnu: Add python-bitstring.

Message ID 20201227221333.23351-5-dftxbs3e@free.fr
State Accepted
Headers show
Series gnu: electrum: Update to 4.0.9. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

dftxbs3e Dec. 27, 2020, 10:13 p.m. UTC
* gnu/packages/python-xyz.scm (python-bitstring): New variable.
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2df26dffbf..b06f6011de 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23251,3 +23251,24 @@  environment.")
     (description
       "QDarkStyle is the most complete dark stylesheet for Python and Qt applications.")
     (license license:expat)))
+
+(define-public python-bitstring
+  (package
+    (name "python-bitstring")
+    (version "3.1.7")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "bitstring" version))
+        (sha256
+          (base32
+            "0jl6192dwrlm5ybkbh7ywmyaymrc3cmz9y07nm7qdli9n9rfpwzx"))))
+    (build-system python-build-system)
+    (home-page
+      "https://github.com/scott-griffiths/bitstring")
+    (synopsis
+      "Simple construction, analysis and modification of binary data")
+    (description
+      "Bitstring is a library for simple construction, analysis and modification
+ of binary data.")
+    (license license:expat)))