diff mbox series

[bug#44990,v3,2/8] gnu: Add python-helpdev.

Message ID 20201227221333.23351-3-dftxbs3e@free.fr
State Accepted
Headers show
Series gnu: electrum: Update to 4.0.9. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

dftxbs3e Dec. 27, 2020, 10:13 p.m. UTC
* gnu/packages/python-xyz.scm (python-helpdev): New variable.
---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index acde5a5e5e..47edaabc0c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23201,3 +23201,26 @@  backport of the @code{dataclasses} module for Python 3.6.")
     (description "@code{python-pywatchman} is a library to connect and
 query Watchman to discover file changes.")
     (license license:bsd-3)))
+
+(define-public python-helpdev
+  (package
+    (name "python-helpdev")
+    (version "0.7.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "helpdev" version))
+        (sha256
+          (base32
+            "0gfvj28i82va7c264jl2p4cdsl3lpf9fpb9cyjnis55crfdafqmv"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      `(("python-importlib-metadata"
+         ,python-importlib-metadata)))
+    (home-page "https://gitlab.com/dpizetta/helpdev")
+    (synopsis
+      "Extracts information about the Python environment easily")
+    (description
+      "Helpdev is a library to easily extract information about the Python
+environment.")
+    (license license:expat)))