diff mbox series

[bug#44969,4/7] gnu: Added go-github-com-gorilla-securecookie.

Message ID 20201130202408.27437-4-mjbecze@riseup.net
State Accepted
Headers show
Series Update trezord to 2.0.30 | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Martin Becze Nov. 30, 2020, 8:24 p.m. UTC
* gnu/packages/golang.scm (go-github-com-gorilla-securecookie): New variable.
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 97becc2a4b..7a2d62a752 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1357,6 +1357,29 @@  incoming requests with their respective handler.")
 and web applications.")
     (license license:bsd-3)))
 
+(define-public go-github-com-gorilla-securecookie
+  (package
+    (name "go-github-com-gorilla-securecookie")
+    (version "1.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/gorilla/securecookie")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "16bqimpxs9vj5n59vm04y04v665l7jh0sddxn787pfafyxcmh410"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/gorilla/securecookie"))
+    (home-page "https://github.com/gorilla/securecookie")
+    (synopsis "Encodes and decodes authenticated and optionally encrypted cookie values")
+    (description "Gorilla/securecookie encodes and decodes authenticated and optionally
+encrypted cookie values for Go web applications.")
+    (license license:bsd-3)))
+
 (define-public go-github-com-jonboulle-clockwork
   (let ((commit "e3653ace2d63753697e0e5b07b9393971c0bba9d")
         (revision "0"))