diff mbox series

[bug#44969,1/7] gnu: go-github-com-gorilla-mux: Update to 1.8.0.

Message ID 20201130202408.27437-1-mjbecze@riseup.net
State Accepted
Headers show
Series Update trezord to 2.0.30 | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Martin Becze Nov. 30, 2020, 8:24 p.m. UTC
* gnu/packages/golang.scm (go-github-com-gorilla-mux): Update to 1.8.0.
---
 gnu/packages/golang.scm | 60 ++++++++++++++++++++---------------------
 1 file changed, 29 insertions(+), 31 deletions(-)

Comments

Christopher Baines Dec. 8, 2020, 8:59 a.m. UTC | #1
Martin Becze <mjbecze@riseup.net> writes:

> * gnu/packages/golang.scm (go-github-com-gorilla-mux): Update to 1.8.0.
> ---
>  gnu/packages/golang.scm | 60 ++++++++++++++++++++---------------------
>  1 file changed, 29 insertions(+), 31 deletions(-)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index 92533cfd50..fed32d65ec 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -1307,50 +1307,48 @@ values for the purpose of fuzz testing.")
>        (license license:bsd-3))))
>  
>  (define-public go-github-com-gorilla-mux
> -  (let ((commit "599cba5e7b6137d46ddf58fb1765f5d928e69604")
> +  (package
> +    (name "go-github-com-gorilla-mux")
> +    (version "1.8.0")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/gorilla/mux")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> +         "18f0q9qxgq1yh4ji07mqhiydfcwvi56z9d775v7dc7yckj33kpdk"))))
> +    (build-system go-build-system)
> +    (arguments
> +     '(#:import-path "github.com/gorilla/mux"))
> +    (home-page "https://github.com/gorilla/mux")
> +    (synopsis "URL router and dispatcher for Go")
> +    (description
> +     "Gorilla/Mux implements a request router and dispatcher for matching
> +incoming requests with their respective handler.")
> +    (license license:bsd-3)))
> +
> +(define-public go-github-com-jonboulle-clockwork
> +  (let ((commit "e3653ace2d63753697e0e5b07b9393971c0bba9d")
>          (revision "0"))
>      (package
> -      (name "go-github-com-gorilla-mux")
> +      (name "go-github-com-jonboulle-clockwork")
>        (version (git-version "0.0.0" revision commit))
>        (source
>         (origin
>           (method git-fetch)
>           (uri (git-reference
> -               (url "https://github.com/gorilla/mux")
> +               (url "https://github.com/jonboulle/clockwork")
>                 (commit commit)))
>           (file-name (git-file-name name version))
>           (sha256
>            (base32
> -           "0wd6jjii1kg5s0nk3ri6gqriz6hbd6bbcn6x4jf8n7ncrb8qsxyz"))))
> -      (build-system go-build-system)
> -      (arguments
> -       '(#:import-path "github.com/gorilla/mux"))
> -      (home-page "https://github.com/gorilla/mux")
> -      (synopsis "URL router and dispatcher for Go")
> -      (description
> -       "Gorilla/Mux implements a request router and dispatcher for matching
> -incoming requests with their respective handler.")
> -      (license license:bsd-3))))
> -
> -(define-public go-github-com-jonboulle-clockwork
> -  (let ((commit "e3653ace2d63753697e0e5b07b9393971c0bba9d")
> -        (revision "0"))
> -    (package
> -      (name "go-github-com-jonboulle-clockwork")
> -      (version (git-version "0.0.0" revision commit))
> -      (source
> -        (origin
> -          (method git-fetch)
> -          (uri (git-reference
> -                 (url "https://github.com/jonboulle/clockwork")
> -                 (commit commit)))
> -          (file-name (git-file-name name version))
> -          (sha256
> -            (base32
> -              "1avzqhks12a8x2yzpvjsf3k0gv9cy7zx2z88hn0scacnxkphisvc"))))
> +           "1avzqhks12a8x2yzpvjsf3k0gv9cy7zx2z88hn0scacnxkphisvc"))))
>        (build-system go-build-system)
>        (arguments
> -        '(#:import-path "github.com/jonboulle/clockwork"))
> +       '(#:import-path "github.com/jonboulle/clockwork"))
>        (home-page "https://github.com/jonboulle/clockwork")
>        (synopsis "Fake clock library for Go")
>        (description

This patch is a little messy, I think the
go-github-com-jonboulle-clockwork indentation isn't great, and you end
up changing it when updating go-github-com-gorilla-mux.

I managed to remove the go-github-com-jonboulle-clockwork indentation
changes from this before committing.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 92533cfd50..fed32d65ec 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1307,50 +1307,48 @@  values for the purpose of fuzz testing.")
       (license license:bsd-3))))
 
 (define-public go-github-com-gorilla-mux
-  (let ((commit "599cba5e7b6137d46ddf58fb1765f5d928e69604")
+  (package
+    (name "go-github-com-gorilla-mux")
+    (version "1.8.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/gorilla/mux")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "18f0q9qxgq1yh4ji07mqhiydfcwvi56z9d775v7dc7yckj33kpdk"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/gorilla/mux"))
+    (home-page "https://github.com/gorilla/mux")
+    (synopsis "URL router and dispatcher for Go")
+    (description
+     "Gorilla/Mux implements a request router and dispatcher for matching
+incoming requests with their respective handler.")
+    (license license:bsd-3)))
+
+(define-public go-github-com-jonboulle-clockwork
+  (let ((commit "e3653ace2d63753697e0e5b07b9393971c0bba9d")
         (revision "0"))
     (package
-      (name "go-github-com-gorilla-mux")
+      (name "go-github-com-jonboulle-clockwork")
       (version (git-version "0.0.0" revision commit))
       (source
        (origin
          (method git-fetch)
          (uri (git-reference
-               (url "https://github.com/gorilla/mux")
+               (url "https://github.com/jonboulle/clockwork")
                (commit commit)))
          (file-name (git-file-name name version))
          (sha256
           (base32
-           "0wd6jjii1kg5s0nk3ri6gqriz6hbd6bbcn6x4jf8n7ncrb8qsxyz"))))
-      (build-system go-build-system)
-      (arguments
-       '(#:import-path "github.com/gorilla/mux"))
-      (home-page "https://github.com/gorilla/mux")
-      (synopsis "URL router and dispatcher for Go")
-      (description
-       "Gorilla/Mux implements a request router and dispatcher for matching
-incoming requests with their respective handler.")
-      (license license:bsd-3))))
-
-(define-public go-github-com-jonboulle-clockwork
-  (let ((commit "e3653ace2d63753697e0e5b07b9393971c0bba9d")
-        (revision "0"))
-    (package
-      (name "go-github-com-jonboulle-clockwork")
-      (version (git-version "0.0.0" revision commit))
-      (source
-        (origin
-          (method git-fetch)
-          (uri (git-reference
-                 (url "https://github.com/jonboulle/clockwork")
-                 (commit commit)))
-          (file-name (git-file-name name version))
-          (sha256
-            (base32
-              "1avzqhks12a8x2yzpvjsf3k0gv9cy7zx2z88hn0scacnxkphisvc"))))
+           "1avzqhks12a8x2yzpvjsf3k0gv9cy7zx2z88hn0scacnxkphisvc"))))
       (build-system go-build-system)
       (arguments
-        '(#:import-path "github.com/jonboulle/clockwork"))
+       '(#:import-path "github.com/jonboulle/clockwork"))
       (home-page "https://github.com/jonboulle/clockwork")
       (synopsis "Fake clock library for Go")
       (description