diff mbox series

[bug#44926,v2,02/15] gnu: packages: dart.scm: New file.

Message ID 20201129173414.8984-2-nicolo@nixo.xyz
State New
Headers show
Series [bug#44926,v2,01/15] gnu: Add gn-for-dart-bootstrap. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolò Balzarotti Nov. 29, 2020, 5:34 p.m. UTC
gnu/local.mk: Add it.
gnu/packages/dart.scm (dart-pkg): New function.
---
 gnu/local.mk          |  1 +
 gnu/packages/dart.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 2 files changed, 42 insertions(+)
 create mode 100644 gnu/packages/dart.scm
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 14b626c600..359015415c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -156,6 +156,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/cvassistant.scm			\
   %D%/packages/cybersecurity.scm		\
   %D%/packages/cyrus-sasl.scm			\
+  %D%/packages/dart.scm				\
   %D%/packages/databases.scm			\
   %D%/packages/datamash.scm			\
   %D%/packages/datastructures.scm		\
diff --git a/gnu/packages/dart.scm b/gnu/packages/dart.scm
new file mode 100644
index 0000000000..f8af8696bc
--- /dev/null
+++ b/gnu/packages/dart.scm
@@ -0,0 +1,41 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xy>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages dart)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix build utils)
+  #:use-module (guix git-download)
+  #:use-module (guix packages)
+  #:use-module (guix utils))
+
+(define* (dart-pkg name tag hash #:optional
+                   (url (string-append
+                         "https://github.com/dart-lang/"
+                         (string-replace-substring name "-" "_"))))
+  (origin
+    (method git-fetch)
+    (uri (git-reference
+          (url url)
+          (commit tag)))
+    (file-name
+     (git-file-name name
+                    (if (> (string-length tag) 9)
+                        (string-take tag 9)
+                        tag)))
+    (sha256 (base32 hash))))
+