diff mbox series

[bug#44803,1/2] gnu: Add elementary-xfce-icon-theme.

Message ID 20201122172002.14697-1-kkebreau@posteo.net
State Accepted
Headers show
Series [bug#44803,1/2] gnu: Add elementary-xfce-icon-theme. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Kei Kebreau Nov. 22, 2020, 5:20 p.m. UTC
* gnu/packages/xfce.scm (elementary-xfce-icon-theme): New variable.
---
 gnu/packages/xfce.scm | 38 +++++++++++++++++++++++++++++++++++++-
 1 file changed, 37 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 02e8093ddf..0d3328af3c 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -3,7 +3,7 @@ 
 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2016 Florian Paul Schmidt <mista.tapas@gmx.net>
-;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2016, 2020 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2017 Petter <petter@mykolab.ch>
 ;;; Copyright © 2017 Nikita <nikita@n0.is>
@@ -64,6 +64,7 @@ 
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system trivial)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix gexp)
   #:use-module ((guix licenses) #:hide (freetype))
   #:use-module (guix packages)
@@ -202,6 +203,41 @@  storage system.")
 to share commonly used Xfce widgets among the Xfce applications.")
     (license lgpl2.0+)))
 
+(define-public elementary-xfce-icon-theme
+  (package
+    (name "elementary-xfce-icon-theme")
+    (version "0.15.1")
+    (source (origin
+              (method git-fetch)
+              (uri
+               (git-reference
+                (url "https://github.com/shimmerproject/elementary-xfce.git")
+                (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1rl15kh9c7qxw4pvwmw44fb4v3vwh6zin4wpx55bnvm5j76y6p3f"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:tests? #f                      ; no check target
+       #:make-flags '("CC=gcc")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'make-git-checkout-writable
+           (lambda _
+             (for-each make-file-writable (find-files "."))
+             #t)))))
+    (native-inputs
+     `(("gtk+" ,gtk+)
+       ("optipng" ,optipng)
+       ("pkg-config" ,pkg-config)))
+    (home-page "https://shimmerproject.org/")
+    (synopsis "Elementary icons extended and maintained for Xfce")
+    (description "This is a fork of the upstream elementary project.  This
+icon-theme is supposed to keep everything working, but gets updates from
+upstream occasionally.")
+    (license gpl2+)))
+
 (define-public exo
   (package
     (name "exo")