diff mbox series

[bug#44803,2/2] gnu: Add greybird-gtk-theme.

Message ID 20201122172432.15384-1-kkebreau@posteo.net
State Accepted
Headers show
Series [bug#44803,1/2] gnu: Add elementary-xfce-icon-theme. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Kei Kebreau Nov. 22, 2020, 5:24 p.m. UTC
* gnu/packages/gnome-xyz.scm (greybird-gtk-theme): New variable.
---
 gnu/packages/gnome-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Kei Kebreau Nov. 27, 2020, 8:01 p.m. UTC | #1
Kei Kebreau <kkebreau@posteo.net> writes:

> * gnu/packages/gnome-xyz.scm (greybird-gtk-theme): New variable.
> ---
>  gnu/packages/gnome-xyz.scm | 30 ++++++++++++++++++++++++++++++
>  1 file changed, 30 insertions(+)
>
> diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
> index d69f14ba0e..bdf80ae2ac 100644
> --- a/gnu/packages/gnome-xyz.scm
> +++ b/gnu/packages/gnome-xyz.scm
> @@ -4,6 +4,7 @@
>  ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
>  ;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
>  ;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
> +;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
>  ;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
>  ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
>  ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
> @@ -42,6 +43,7 @@
>    #:use-module (gnu packages ssh)
>    #:use-module (gnu packages tls)
>    #:use-module (gnu packages ruby)
> +  #:use-module (gnu packages web)
>    #:use-module (gnu packages xml))
>  
>  (define-public matcha-theme
> @@ -515,6 +517,34 @@ scrollable tiling of windows and per monitor workspaces.  It's inspired by paper
>  notebooks and tiling window managers.")
>      (license license:gpl3)))
>  
> +(define-public greybird-gtk-theme
> +  (package
> +    (name "greybird-gtk-theme")
> +    (version "3.22.12")
> +    (source (origin
> +              (method git-fetch)
> +              (uri
> +               (git-reference
> +                (url "https://github.com/shimmerproject/Greybird.git")
> +                (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "1j66ddvl3pmwh2v8ajm8r5g5nbsr7r262ff1qn2nf3i0gy8b3lq8"))))
> +    (build-system meson-build-system)
> +    (native-inputs
> +     `(("gtk+" ,gtk+)
> +       ("glib:bin" ,glib "bin")         ; for "glib-compile-resources"
> +       ("librsvg" ,librsvg)
> +       ("pkg-config" ,pkg-config)
> +       ("ruby-sass" ,ruby-sass)
> +       ("sassc" ,sassc)))
> +    (home-page "https://shimmerproject.org/")
> +    (synopsis "Grey GTK+ theme based on Bluebird")
> +    (description "Greybird is a grey derivative of the Bluebird theme by the
> +Shimmer Project.  It supports GNOME, Unity, and Xfce.")
> +    (license (list license:gpl2+ license:cc-by-sa3.0))))
> +
>  (define-public numix-gtk-theme
>    (package
>      (name "numix-gtk-theme")

Pushed to master as commits 213be7c5e4 and f43e7462d8.
Kei Kebreau Nov. 27, 2020, 8:04 p.m. UTC | #2
> Pushed to master as commits 213be7c5e4 and f43e7462d8.
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index d69f14ba0e..bdf80ae2ac 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
@@ -42,6 +43,7 @@ 
   #:use-module (gnu packages ssh)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages ruby)
+  #:use-module (gnu packages web)
   #:use-module (gnu packages xml))
 
 (define-public matcha-theme
@@ -515,6 +517,34 @@  scrollable tiling of windows and per monitor workspaces.  It's inspired by paper
 notebooks and tiling window managers.")
     (license license:gpl3)))
 
+(define-public greybird-gtk-theme
+  (package
+    (name "greybird-gtk-theme")
+    (version "3.22.12")
+    (source (origin
+              (method git-fetch)
+              (uri
+               (git-reference
+                (url "https://github.com/shimmerproject/Greybird.git")
+                (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1j66ddvl3pmwh2v8ajm8r5g5nbsr7r262ff1qn2nf3i0gy8b3lq8"))))
+    (build-system meson-build-system)
+    (native-inputs
+     `(("gtk+" ,gtk+)
+       ("glib:bin" ,glib "bin")         ; for "glib-compile-resources"
+       ("librsvg" ,librsvg)
+       ("pkg-config" ,pkg-config)
+       ("ruby-sass" ,ruby-sass)
+       ("sassc" ,sassc)))
+    (home-page "https://shimmerproject.org/")
+    (synopsis "Grey GTK+ theme based on Bluebird")
+    (description "Greybird is a grey derivative of the Bluebird theme by the
+Shimmer Project.  It supports GNOME, Unity, and Xfce.")
+    (license (list license:gpl2+ license:cc-by-sa3.0))))
+
 (define-public numix-gtk-theme
   (package
     (name "numix-gtk-theme")