diff mbox series

[bug#44640,3/3] gnu: Add python-git-hammer.

Message ID 20201114170047.949-3-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series Add python-git-hammer | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Leo Prikler Nov. 14, 2020, 5 p.m. UTC
* gnu/packages/python-xyz.scm (python-git-hammer): New variable.
---
 gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Efraim Flashner Nov. 17, 2020, 10:50 a.m. UTC | #1
Not a full review, building other packages atm

On Sat, Nov 14, 2020 at 06:00:48PM +0100, Leo Prikler wrote:
> * gnu/packages/python-xyz.scm (python-git-hammer): New variable.
> ---
>  gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
>  1 file changed, 31 insertions(+)
> 
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 7b9ab21671..c5da6b24d6 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -18296,6 +18296,37 @@ supports the globstar @code{**} operator to match an arbitrary number of
>  path components.")
>      (license license:asl2.0)))
>  

Does it make more sense to put this in version-control than in
python-xyz? Can it be used as a library or is it really just a program
run on its own?

> +(define-public python-git-hammer
> +  (package
> +    (name "python-git-hammer")
> +    (version "0.3.1")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "git-hammer" version))
> +       (sha256
> +        (base32
> +         "16kcijngd3v6f0ym1j4qb6sp08cqb3iprqn080k3yqgd0b17dfc6"))))
> +    (build-system python-build-system)
> +    (arguments
> +     `(#:tests? #f)) ; missing from distribution

Let's build this one from git also, then we can run the tests

> +    (propagated-inputs

These don't need to be propagated if this is an "application" and not a
"library". They can just be regular inputs.

> +     `(("python-beautifultable" ,python-beautifultable)
> +       ("python-dateutil" ,python-dateutil)
> +       ("python-gitpython" ,python-gitpython)
> +       ("python-globber" ,python-globber)
> +       ("python-matplotlib" ,python-matplotlib)
> +       ("python-sqlalchemy" ,python-sqlalchemy)
> +       ("python-sqlalchemy-utils"
> +        ,python-sqlalchemy-utils)))
> +    (home-page "https://github.com/asharov/git-hammer")
> +    (synopsis "Provide statistics for git repositories")
> +    (description
> +     "Git Hammer is a statistics tool for projects in git repositories.
> +Its major feature is tracking the number of lines authored by each person for every
> +commit, but it also includes some other useful statistics.")
> +    (license license:asl2.0)))
> +
>  (define-public python-fusepy
>    (package
>      (name "python-fusepy")
> -- 
> 2.29.2
> 
> 
> 
>
Leo Prikler Nov. 17, 2020, 11:01 a.m. UTC | #2
Hello,

Am Dienstag, den 17.11.2020, 12:50 +0200 schrieb Efraim Flashner:
> Not a full review, building other packages atm
> 
> On Sat, Nov 14, 2020 at 06:00:48PM +0100, Leo Prikler wrote:
> > * gnu/packages/python-xyz.scm (python-git-hammer): New variable.
> > ---
> >  gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
> >  1 file changed, 31 insertions(+)
> > 
> > diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-
> > xyz.scm
> > index 7b9ab21671..c5da6b24d6 100644
> > --- a/gnu/packages/python-xyz.scm
> > +++ b/gnu/packages/python-xyz.scm
> > @@ -18296,6 +18296,37 @@ supports the globstar @code{**} operator
> > to match an arbitrary number of
> >  path components.")
> >      (license license:asl2.0)))
> >  
> 
> Does it make more sense to put this in version-control than in
> python-xyz? Can it be used as a library or is it really just a
> program
> run on its own?
I suppose it can.  To begin with, there is not even an executable,
you're supposed to run it using `python -m githammer`.

> > +(define-public python-git-hammer
> > +  (package
> > +    (name "python-git-hammer")
> > +    (version "0.3.1")
> > +    (source
> > +     (origin
> > +       (method url-fetch)
> > +       (uri (pypi-uri "git-hammer" version))
> > +       (sha256
> > +        (base32
> > +         "16kcijngd3v6f0ym1j4qb6sp08cqb3iprqn080k3yqgd0b17dfc6")))
> > )
> > +    (build-system python-build-system)
> > +    (arguments
> > +     `(#:tests? #f)) ; missing from distribution
> 
> Let's build this one from git also, then we can run the tests
I'm on it, same for 2/3.

> > +    (propagated-inputs
> 
> These don't need to be propagated if this is an "application" and not
> a
> "library". They can just be regular inputs.
See my comment above.

> > +     `(("python-beautifultable" ,python-beautifultable)
> > +       ("python-dateutil" ,python-dateutil)
> > +       ("python-gitpython" ,python-gitpython)
> > +       ("python-globber" ,python-globber)
> > +       ("python-matplotlib" ,python-matplotlib)
> > +       ("python-sqlalchemy" ,python-sqlalchemy)
> > +       ("python-sqlalchemy-utils"
> > +        ,python-sqlalchemy-utils)))
> > +    (home-page "https://github.com/asharov/git-hammer")
> > +    (synopsis "Provide statistics for git repositories")
> > +    (description
> > +     "Git Hammer is a statistics tool for projects in git
> > repositories.
> > +Its major feature is tracking the number of lines authored by each
> > person for every
> > +commit, but it also includes some other useful statistics.")
> > +    (license license:asl2.0)))
> > +
> >  (define-public python-fusepy
> >    (package
> >      (name "python-fusepy")
> > -- 
> > 2.29.2

Regards, Leo
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7b9ab21671..c5da6b24d6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18296,6 +18296,37 @@  supports the globstar @code{**} operator to match an arbitrary number of
 path components.")
     (license license:asl2.0)))
 
+(define-public python-git-hammer
+  (package
+    (name "python-git-hammer")
+    (version "0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "git-hammer" version))
+       (sha256
+        (base32
+         "16kcijngd3v6f0ym1j4qb6sp08cqb3iprqn080k3yqgd0b17dfc6"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f)) ; missing from distribution
+    (propagated-inputs
+     `(("python-beautifultable" ,python-beautifultable)
+       ("python-dateutil" ,python-dateutil)
+       ("python-gitpython" ,python-gitpython)
+       ("python-globber" ,python-globber)
+       ("python-matplotlib" ,python-matplotlib)
+       ("python-sqlalchemy" ,python-sqlalchemy)
+       ("python-sqlalchemy-utils"
+        ,python-sqlalchemy-utils)))
+    (home-page "https://github.com/asharov/git-hammer")
+    (synopsis "Provide statistics for git repositories")
+    (description
+     "Git Hammer is a statistics tool for projects in git repositories.
+Its major feature is tracking the number of lines authored by each person for every
+commit, but it also includes some other useful statistics.")
+    (license license:asl2.0)))
+
 (define-public python-fusepy
   (package
     (name "python-fusepy")