diff mbox series

[bug#44640,2/3] gnu: Add python-globber.

Message ID 20201114170047.949-2-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series Add python-git-hammer | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Leo Prikler Nov. 14, 2020, 5 p.m. UTC
* gnu/packages/python-xyz.scm (python-globber): New variable.
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Efraim Flashner Nov. 17, 2020, 10:48 a.m. UTC | #1
Not a full review (currently building other packages...)

On Sat, Nov 14, 2020 at 06:00:47PM +0100, Leo Prikler wrote:
> * gnu/packages/python-xyz.scm (python-globber): New variable.
> ---
>  gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)
> 
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 57371f05c7..7b9ab21671 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -18271,6 +18271,31 @@ Features include, but are not limited to:
>  @end itemize")
>      (license license:expat)))
>  
> +(define-public python-globber
> +  (package
> +    (name "python-globber")
> +    (version "0.2.1")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "globber" version))
> +       (sha256
> +        (base32
> +         "0w7gaqpfc9j9l6hgm0cl7hrlf3lr0w7ifns035cksa1r16mhlwlr"))))
> +    (build-system python-build-system)
> +    (arguments
> +     `(#:tests? #f)) ; missing from distribution

Can we build from a git checkout then? It's better to have the tests and
run them.

> +    (home-page "https://github.com/asharov/globber")
> +    (synopsis
> +     "Library for string matching with glob patterns")

Can you put this on the previous line? It triggers something inside me
to have it on its own line when it's not approaching 80 characters :/

> +    (description
> +     "Globber is a Python library for matching file names against glob patterns.
> +In contrast to other glob-matching libraries, it matches arbitrary strings and
> +doesn't require the matched names to be existing files.  In addition, it
> +supports the globstar @code{**} operator to match an arbitrary number of
> +path components.")
> +    (license license:asl2.0)))
> +
>  (define-public python-fusepy
>    (package
>      (name "python-fusepy")
> -- 
> 2.29.2
> 
> 
> 
>
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 57371f05c7..7b9ab21671 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18271,6 +18271,31 @@  Features include, but are not limited to:
 @end itemize")
     (license license:expat)))
 
+(define-public python-globber
+  (package
+    (name "python-globber")
+    (version "0.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "globber" version))
+       (sha256
+        (base32
+         "0w7gaqpfc9j9l6hgm0cl7hrlf3lr0w7ifns035cksa1r16mhlwlr"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f)) ; missing from distribution
+    (home-page "https://github.com/asharov/globber")
+    (synopsis
+     "Library for string matching with glob patterns")
+    (description
+     "Globber is a Python library for matching file names against glob patterns.
+In contrast to other glob-matching libraries, it matches arbitrary strings and
+doesn't require the matched names to be existing files.  In addition, it
+supports the globstar @code{**} operator to match an arbitrary number of
+path components.")
+    (license license:asl2.0)))
+
 (define-public python-fusepy
   (package
     (name "python-fusepy")