diff mbox series

[bug#43991] gnu: r-sf: Use proj instead of proj.4.

Message ID 20201014172405.1910-1-wz@freeshell.de
State Accepted
Headers show
Series [bug#43991] gnu: r-sf: Use proj instead of proj.4. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Wiktor Żelazny Oct. 14, 2020, 5:24 p.m. UTC
From: Wiktor Żelazny <wzelazny@vurv.cz>

* gnu/packages/cran.scm (r-sf)[inputs]: Replace proj.4 with proj, and
add sqlite.

This addresses segfaults while loading vector GIS data from a file.
---
 gnu/packages/cran.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Comments

Christopher Baines Oct. 15, 2020, 8:11 p.m. UTC | #1
Wiktor Żelazny <wz@freeshell.de> writes:

> From: Wiktor Żelazny <wzelazny@vurv.cz>
>
> * gnu/packages/cran.scm (r-sf)[inputs]: Replace proj.4 with proj, and
> add sqlite.
>
> This addresses segfaults while loading vector GIS data from a file.
> ---
>  gnu/packages/cran.scm | 6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
> index 59a409f8e9..252699c691 100644
> --- a/gnu/packages/cran.scm
> +++ b/gnu/packages/cran.scm
> @@ -17,7 +17,7 @@
>  ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
>  ;;; Copyright © 2018, 2019 Brett Gilio <brettg@gnu.org>
>  ;;; Copyright © 2019 Nicolò Balzarotti <anothersms@gmail.com>
> -;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
> +;;; Copyright © 2019, 2020 Wiktor Żelazny <wzelazny@vurv.cz>
>  ;;; Copyright © 2019 Arne Babenhauserheide <arne_bab@web.de>
>  ;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
>  ;;; Copyright © 2020 Todor Kondić <tk.code@protonmail.com>
> @@ -90,6 +90,7 @@
>    #:use-module (gnu packages pulseaudio)  ;libsndfile
>    #:use-module (gnu packages python)
>    #:use-module (gnu packages python-xyz)
> +  #:use-module (gnu packages sqlite)
>    #:use-module (gnu packages statistics)
>    #:use-module (gnu packages tcl)
>    #:use-module (gnu packages tls)
> @@ -13957,7 +13958,8 @@ tessellation.")
>      (inputs
>       `(("gdal" ,gdal)
>         ("geos" ,geos)
> -       ("proj" ,proj.4)
> +       ("proj" ,proj)
> +       ("sqlite" ,sqlite)
>         ("zlib" ,zlib)))
>      (propagated-inputs
>       `(("r-classint" ,r-classint)

Looks good :) I tweaked the commit message slightly, just because I'd
normally put the changelog at the end, but I've pushed to master as
ae6a61d7311cde7ccb863bcff57e26f7674ebc18. Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 59a409f8e9..252699c691 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17,7 +17,7 @@ 
 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2018, 2019 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2019 Nicolò Balzarotti <anothersms@gmail.com>
-;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
+;;; Copyright © 2019, 2020 Wiktor Żelazny <wzelazny@vurv.cz>
 ;;; Copyright © 2019 Arne Babenhauserheide <arne_bab@web.de>
 ;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 Todor Kondić <tk.code@protonmail.com>
@@ -90,6 +90,7 @@ 
   #:use-module (gnu packages pulseaudio)  ;libsndfile
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages sqlite)
   #:use-module (gnu packages statistics)
   #:use-module (gnu packages tcl)
   #:use-module (gnu packages tls)
@@ -13957,7 +13958,8 @@  tessellation.")
     (inputs
      `(("gdal" ,gdal)
        ("geos" ,geos)
-       ("proj" ,proj.4)
+       ("proj" ,proj)
+       ("sqlite" ,sqlite)
        ("zlib" ,zlib)))
     (propagated-inputs
      `(("r-classint" ,r-classint)