diff mbox series

[bug#43928] gnu: knot: Update to 3.0.1.

Message ID 20201011160745.19178-1-simon@simonsouth.net
State Accepted
Headers show
Series [bug#43928] gnu: knot: Update to 3.0.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Simon South Oct. 11, 2020, 4:07 p.m. UTC
* gnu/packages/dns.scm (knot): Update to 3.0.1.
[source]: Remove obsolete patch.
* gnu/packages/patches/knot-test_net_shortwrite-ensure-connection.patch:
Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
---
 gnu/local.mk                                  |  1 -
 gnu/packages/dns.scm                          |  6 ++----
 ...est_net_shortwrite-ensure-connection.patch | 19 -------------------
 3 files changed, 2 insertions(+), 24 deletions(-)
 delete mode 100644 gnu/packages/patches/knot-test_net_shortwrite-ensure-connection.patch

Comments

Simon South Oct. 13, 2020, 7:28 p.m. UTC | #1
This change has been made by another contributor, so the report can be
closed.
Tobias Geerinckx-Rice Oct. 13, 2020, 7:45 p.m. UTC | #2
Simon South 写道:
> This change has been made by another contributor, so the report 
> can be
> closed.

I like to run new Knots for a day or two before pushing.  One of 
the 2.x's would crash after a while and caused me to lose mail. 
My set-up's since become a lot more robust, but still.

Thanks anyway!

T G-R
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index b59b122e86..ff77e801ff 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1198,7 +1198,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/kpackage-allow-external-paths.patch	\
   %D%/packages/patches/kmplayer-aarch64.patch			\
   %D%/packages/patches/kmplayer-upstream_Fix-build-with-Qt-5.9.patch	\
-  %D%/packages/patches/knot-test_net_shortwrite-ensure-connection.patch	\
   %D%/packages/patches/kobodeluxe-paths.patch			\
   %D%/packages/patches/kobodeluxe-enemies-pipe-decl.patch	\
   %D%/packages/patches/kobodeluxe-const-charp-conversion.patch	\
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 5b159bc656..0cf07853e0 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -807,7 +807,7 @@  Extensions} (DNSSEC).")
 (define-public knot
   (package
     (name "knot")
-    (version "3.0.0")
+    (version "3.0.1")
     (source
      (origin
        (method git-fetch)
@@ -816,9 +816,7 @@  Extensions} (DNSSEC).")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0fkvip7n5ihjfwnnivdc3jf44y8p85ifglvq7b0anxvj9cg1m78f"))
-       (patches
-        (search-patches "knot-test_net_shortwrite-ensure-connection.patch"))
+        (base32 "10mlzldxqvbaw78nghkr0s73rlbpz9wg16z14321xw2l9xfibkad"))
        (modules '((guix build utils)))
        (snippet
         '(begin
diff --git a/gnu/packages/patches/knot-test_net_shortwrite-ensure-connection.patch b/gnu/packages/patches/knot-test_net_shortwrite-ensure-connection.patch
deleted file mode 100644
index 8b57ec522e..0000000000
--- a/gnu/packages/patches/knot-test_net_shortwrite-ensure-connection.patch
+++ /dev/null
@@ -1,19 +0,0 @@ 
-This patch duplicates upstream commit 4144d1e, which helps ensure the
-"test_net_shortwrite" test suite can succeed across all platforms by
-deepening the pending-connection queue of the server it creates from 0
-to 1.
-
-See the original report at
-https://gitlab.nic.cz/knot/knot-dns/-/issues/693
-
---- a/tests/contrib/test_net_shortwrite.c
-+++ b/tests/contrib/test_net_shortwrite.c
-@@ -88,7 +88,7 @@ int main(int argc, char *argv[])
-	int server = net_bound_socket(SOCK_STREAM, &addr, 0);
-	ok(server >= 0, "server: bind socket");
-
--	r = listen(server, 0);
-+	r = listen(server, 1);
-	ok(r == 0, "server: start listening");
-
-	struct sockaddr *sa = (struct sockaddr *)&addr;