diff mbox series

[bug#43345,03/12] gnu: r-diffusionmap: Move to (gnu packages cran).

Message ID 20200911180849.12582-3-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Move some CRAN packages to (gnu packages cran). | expand

Commit Message

Simon Tournier Sept. 11, 2020, 6:08 p.m. UTC
* gnu/packages/graph.scm (r-diffusionmap): Move from here ...
* gnu/packages/cran.scm (r-diffusionmap): ... to here.
---
 gnu/packages/cran.scm  | 25 +++++++++++++++++++++++++
 gnu/packages/graph.scm | 25 -------------------------
 2 files changed, 25 insertions(+), 25 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f701b7fde0..d539dc34a3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -23643,3 +23643,28 @@  value.")
 adaptive sparsity and the Wong algorithm for adaptively sparse gaussian
 geometric models.")
     (license license:lgpl3+)))
+
+(define-public r-diffusionmap
+  (package
+    (name "r-diffusionmap")
+    (version "1.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "diffusionMap" version))
+       (sha256
+        (base32
+         "1rvk7069brlm1s9kqj4c31mwwr3mw4hmhay95cjjjfmw5xclff2j"))))
+    (properties `((upstream-name . "diffusionMap")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-igraph" ,r-igraph)
+       ("r-matrix" ,r-matrix)
+       ("r-scatterplot3d" ,r-scatterplot3d)))
+    (home-page "https://www.r-project.org")
+    (synopsis "Diffusion map")
+    (description "This package implements the diffusion map method of data
+parametrization, including creation and visualization of diffusion maps,
+clustering with diffusion K-means and regression using the adaptive regression
+model.")
+    (license license:gpl2)))
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 800b567e39..54ced01f6c 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -153,31 +153,6 @@  random and regular graphs, graph visualization, centrality methods and much
 more.")
     (license license:gpl2+)))
 
-(define-public r-diffusionmap
-  (package
-    (name "r-diffusionmap")
-    (version "1.2.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (cran-uri "diffusionMap" version))
-       (sha256
-        (base32
-         "1rvk7069brlm1s9kqj4c31mwwr3mw4hmhay95cjjjfmw5xclff2j"))))
-    (properties `((upstream-name . "diffusionMap")))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-igraph" ,r-igraph)
-       ("r-matrix" ,r-matrix)
-       ("r-scatterplot3d" ,r-scatterplot3d)))
-    (home-page "https://www.r-project.org")
-    (synopsis "Diffusion map")
-    (description "This package implements the diffusion map method of data
-parametrization, including creation and visualization of diffusion maps,
-clustering with diffusion K-means and regression using the adaptive regression
-model.")
-    (license license:gpl2)))
-
 (define-public r-rgraphviz
   (package
     (name "r-rgraphviz")