diff mbox series

[bug#43342,2/3] gnu: gccgo: Reword synopsis and description.

Message ID 20200911160800.22518-2-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Fix #43303 GCC package name | expand

Commit Message

Simon Tournier Sept. 11, 2020, 4:07 p.m. UTC
Fixes <https://bugs.gnu.org/43303>.
Reported by Jeffrey Walton <noloader@gmail.com>.

* gnu/packages/gcc.scm: (gccgo-4.9): Add synopsis and description
---
 gnu/packages/gcc.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index c74477aed9..4d5aaa7070 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -773,7 +773,13 @@  misnomer.")))
 
 
 (define-public gccgo-4.9
-  (custom-gcc gcc-4.9 "gccgo" '("go")
+  (custom-gcc (package
+                (inherit gcc-4.9)
+                (synopsis "Go frontend to GCC")
+                (description
+                 "This package is part of the GNU Compiler Collection and
+provides the GNU compiler for the Go programming language."))
+              "gccgo" '("go")
               %generic-search-paths
               ;; Suppress the separate "lib" output, because otherwise the
               ;; "lib" and "out" outputs would refer to each other, creating