diff mbox series

[bug#43342,1/3] gnu: libgccjit: Reword synopsis and description.

Message ID 20200911160800.22518-1-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Fix #43303 GCC package name | expand

Commit Message

Simon Tournier Sept. 11, 2020, 4:07 p.m. UTC
Fixes <https://bugs.gnu.org/43303>.
Reported by Jeffrey Walton <noloader@gmail.com>.

* gnu/packages/gcc.scm: (libgccjit)[synopsis,description]: Reword.
---
 gnu/packages/gcc.scm | 12 +++++++++++-
 1 file changed, 11 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index a39ac3b84c..c74477aed9 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
 ;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
+;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -759,7 +760,16 @@  as the 'native-search-paths' field."
                (for-each delete-file
                          (find-files (string-append (assoc-ref outputs "out") "/bin")
                                      ".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc|gcc-.*)"))
-               #t))))))))
+               #t))))))
+    (synopsis "GCC library generating machine code on-the-fly at runtime")
+    (description
+     "This package is part of the GNU Compiler Collection and provides an
+embeddable library for generating machine code on-the-fly at runtime.  This
+shared library can then be dynamically-linked into bytecode interpreters and
+other such programs that want to generate machine code on-the-fly at run-time.
+It can also be used for ahead-of-time code generation for building standalone
+compilers.  The just-in-time (jit) part of the name is now something of a
+misnomer.")))
 
 
 (define-public gccgo-4.9