diff mbox series

[bug#43030,5/8] gnu: Add python-simpleeval.

Message ID 20200824222018.23116-4-monego@posteo.net
State Accepted
Headers show
Series [bug#43030,1/8] gnu: Add python-forex-python. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/applying patch fail View Laminar job

Commit Message

Vinicius Monego Aug. 24, 2020, 10:20 p.m. UTC
* gnu/packages/python-xyz.scm (python-simpleeval): New variable.
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index adecc49b78..66d161474a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9496,6 +9496,27 @@  Features:
 @end itemize")
     (license license:expat)))
 
+(define-public python-simpleeval
+  (package
+    (name "python-simpleeval")
+    (version "0.9.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "simpleeval" version))
+       (sha256
+        (base32 "1skvl467kj83rzkhk01i0wm8m5vmh6j5znrfdizn6r18ii45a839"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/danthedeckie/simpleeval")
+    (synopsis "Simple, safe single expression evaluator library")
+    (description
+     "This package provides a quick single file library for easily adding
+evaluatable expressions into python projects.  Say you want to allow a user
+to set an alarm volume, which could depend on the time of day, alarm level,
+how many previous alarms had gone off, and if there is music playing at the
+time.")
+    (license license:expat)))
+
 (define-public python-nbconvert
   (package
     (name "python-nbconvert")