diff mbox series

[bug#43030,1/8] gnu: Add python-forex-python.

Message ID 20200824221748.22871-1-monego@posteo.net
State Accepted
Headers show
Series [bug#43030,1/8] gnu: Add python-forex-python. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/applying patch fail View Laminar job

Commit Message

Vinicius Monego Aug. 24, 2020, 10:17 p.m. UTC
* gnu/packages/python-xyz.scm (python-forex-python): New variable.
---
 gnu/packages/python-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comments

Mathieu Othacehe Aug. 25, 2020, 2:49 p.m. UTC | #1
Hello,

Nice job, thanks for your contribution :)

> +     "Forex Python is a Free Foreign exchange rates and currency conversion.

I edited this description and pushed the whole serie.

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e1b1729b43..adecc49b78 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9460,6 +9460,42 @@  functions to find and load entry points.")
 from elisp.")
     (license license:gpl3)))
 
+(define-public python-forex-python
+  (package
+    (name "python-forex-python")
+    (version "1.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "forex-python" version))
+       (sha256
+        (base32 "1ma8cl1i2dh8aa99pifnlilyy4d1gd1s07fj0yd17wcbpsh532cj"))))
+    (build-system python-build-system)
+    (arguments
+     ;; Tests are not included in the PyPI tarball.  Also, the tests in the
+     ;; repository require online data.
+     `(#:tests? #f))
+    (propagated-inputs
+     `(("python-requests" ,python-requests)
+       ("python-simplejson" ,python-simplejson)))
+    (home-page "https://github.com/MicroPyramid/forex-python")
+    (synopsis "Foreign exchange rates and currency conversion")
+    (description
+     "Forex Python is a Free Foreign exchange rates and currency conversion.
+
+Features:
+@itemize
+@item List all currency rates.
+@item BitCoin price for all currencies.
+@item Converting amount to BitCoins.
+@item Get historical rates for any day since 1999.
+@item Conversion rate for one currency(ex; USD to INR).
+@item Convert amount from one currency to other.('USD 10$' to INR).
+@item Currency symbols.
+@item Currency names.
+@end itemize")
+    (license license:expat)))
+
 (define-public python-nbconvert
   (package
     (name "python-nbconvert")