diff mbox series

[bug#42744,4/4] gnu: Add python-pytest-trio.

Message ID 20200807132416.49309-4-monego@posteo.net
State Accepted
Headers show
Series [bug#42741,1/4] gnu: Add python-outcome. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Vinicius Monego Aug. 7, 2020, 1:24 p.m. UTC
* gnu/packages/python-check.scm (python-pytest-trio): New variable.
---
This pytest line was taken from pytest.ini the source code. Tests were failing
with simpler commands.

 gnu/packages/python-check.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Efraim Flashner Aug. 9, 2020, 11:56 a.m. UTC | #1
Thanks! Pushed as 51431f0b9fe7a2b2aba12287fc9ec9a31cc1a36f
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 7a84fe39f9..d0bde27e13 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -436,6 +436,39 @@  in Pytest.")
 of the project to ensure it renders properly.")
     (license license:expat)))
 
+(define-public python-pytest-trio
+  (package
+    (name "python-pytest-trio")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-trio" version))
+       (sha256
+        (base32 "1zm8didm9h5jkqhghl9bvqs7kr7sjci282c7grhk6yhpzn8a9w4v"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (add-installed-pythonpath inputs outputs)
+             (invoke "pytest" "-W" "error" "-ra" "-v" "--pyargs"
+                     "pytest_trio" "--verbose" "--cov"))))))
+    (native-inputs
+     `(("python-hypothesis" ,python-hypothesis)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)))
+    (propagated-inputs
+     `(("python-trio" ,python-trio)))
+    (home-page "https://github.com/python-trio/pytest-trio")
+    (synopsis "Pytest plugin for trio")
+    (description
+     "This is a pytest plugin to help you test projects that use Trio, a
+friendly library for concurrency and async I/O in Python.")
+    ;; Either license applies.
+    (license (list license:expat license:asl2.0))))
+
 (define-public python-pytest-flake8
   (package
     (name "python-pytest-flake8")