diff mbox series

[bug#42741,1/4] gnu: Add python-outcome.

Message ID 20200807132416.49309-1-monego@posteo.net
State Accepted
Headers show
Series [bug#42741,1/4] gnu: Add python-outcome. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Vinicius Monego Aug. 7, 2020, 1:24 p.m. UTC
* gnu/packages/python-xyz.scm (python-outcome): New variable.
---
 gnu/packages/python-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Brett Gilio Aug. 7, 2020, 6:45 p.m. UTC | #1
Hi Vinicius!

Thanks for your patch series. I just wanted to let you know that best
practice is to send patch series all to the same bug number instead of
opening a new bug number for each patch in the series. Thanks! :)
Vinicius Monego Aug. 7, 2020, 7:30 p.m. UTC | #2
Brett Gilio writes:

> Hi Vinicius!
>
> Thanks for your patch series. I just wanted to let you know that best
> practice is to send patch series all to the same bug number instead of
> opening a new bug number for each patch in the series. Thanks! :)

Hello Brett.

Sure, but that's a problem I'm having with git. I use `git format-patch
[branch] -o folder/` and `git send-email --to="[this list]"
folder/`. Sometimes it sends to one number, sometimes it sends to
different numbers.

I sent two different series for python-h2 and python-sniffio two days
ago using the very same procedure for both. The latter was sent correctly while
the former was sent to different numbers.

Am I missing something?
Vinicius Monego Aug. 8, 2020, 1:35 p.m. UTC | #3
Vinicius Monego writes:

> Am I missing something?

I double checked the documentation for submitting a patch series. I
thought that Git would have tools to automate this (I saw a --thread
flag in the git manpage, but it still didn't group the thread as
expected).

Anyways, I will follow the documentation more closely from now on. Apologies
for the inconvenience :-)
Efraim Flashner Aug. 9, 2020, 11:55 a.m. UTC | #4
Thanks! Pushed as 7d7ad3c946897014cc1ccb7094382b21a8f7b45c
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e4a83a2f37..e15f1a495e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18929,6 +18929,39 @@  easy-to-extend subclass system, and lots of primitive constructs to
 make your work easier.")
     (license license:expat)))
 
+(define-public python-outcome
+  (package
+    (name "python-outcome")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "outcome" version))
+       (sha256
+        (base32 "0vxn04vspmlkkyijjkjnsc46f93ki8g62hr7ag10zpd7ic324y7w"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (add-installed-pythonpath inputs outputs)
+             (invoke "pytest" "-vv"))))))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-asyncio" ,python-pytest-asyncio)))
+    (propagated-inputs
+     `(("python-async-generator" ,python-async-generator)
+       ("python-attrs" ,python-attrs)))
+    (home-page "https://github.com/python-trio/outcome")
+    (synopsis "Capture the outcome of Python function calls")
+    (description
+     "Capture the outcome of Python function calls.  Extracted from the Trio
+project.")
+    ;; Either license applies.
+    (license (list license:expat license:asl2.0))))
+
 (define-public python-humanize
   (package
     (name "python-humanize")