diff mbox series

[bug#42474,3/3] WIP: gnu: Add hunspell-dict-de.

Message ID 20200722123013.7060-3-jonathan.brielmaier@web.de
State Accepted
Headers show
Series WIP: Add hunspell-dict-de. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Jonathan Brielmaier July 22, 2020, 12:30 p.m. UTC
* gnu/packages/libreoffice.scm (hunspell-dict-de): New variable.
---
 gnu/packages/libreoffice.scm | 28 +++++++++++++++++++++++++++-
 1 file changed, 27 insertions(+), 1 deletion(-)

--
2.27.0
diff mbox series

Patch

diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index ebe4fd7246..9e964fb096 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -10,7 +10,7 @@ 
 ;;; Copyright © 2017, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2018 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2018, 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
 ;;; Copyright © 2019 Chris Marusich <cmmarusich@gmail.com>
 ;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
 ;;;
@@ -971,6 +971,32 @@  library.")
     (license
      (list license:gpl2 license:mpl1.1 license:cc-by4.0 license:lgpl2.1 license:asl2.0))))

+(define-public hunspell-dict-de
+  (package
+   (name "hunspell-dict-de")
+   (version "20161207")
+   (source
+    (origin
+      (method url-fetch)
+      (uri (string-append "https://www.j3e.de/ispell/igerman98/dict/"
+                           "igerman98-" version ".tar.bz2"))
+      (sha256 (base32
+               "1a3055hp2bc4q4nlg3gmg0147p3a1zlfnc65xiv2v9pyql1nya8p"))))
+   (build-system gnu-build-system)
+   (arguments
+    `(#:make-flags '("hunspell/de_DE.dic")
+      #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))
+      #:tests? #f)) ;no tests
+   (native-inputs
+    `(("perl" ,perl)))
+   (synopsis "Hunspell dictionary for German")
+   (description "This package provides a dictionary for the Hunspell
+spell-checking library.")
+   (home-page "https://www.j3e.de/ispell/igerman98/")
+   (license (list license:gpl2 license:gpl3))))
+
 (define-public hyphen
   (package
     (name "hyphen")