diff mbox series

[bug#42474,1/3] gnu: Add byacc.

Message ID 20200722123013.7060-1-jonathan.brielmaier@web.de
State Accepted
Headers show
Series WIP: Add hunspell-dict-de. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Jonathan Brielmaier July 22, 2020, 12:30 p.m. UTC
* gnu/packages/c.scm (byacc): New variable.
---
 gnu/packages/c.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

--
2.27.0
diff mbox series

Patch

diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 25bc78e6bf..fde10f5a43 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -10,6 +10,7 @@ 
 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
 ;;; Copyright @ 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -473,3 +474,22 @@  avoiding distractions when studying code that uses @code{#ifdef} heavily for
 portability.")
     (license (list license:bsd-2        ;all files except...
                    license:bsd-3))))    ;...the unidef.1 manual page
+
+(define-public byacc
+  (package
+    (name "byacc")
+    (version "20200330")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://invisible-mirror.net/archives/byacc/"
+                           "byacc-" version ".tgz"))
+       (sha256
+        (base32
+         "1c0zyn6v286i09jlc8gx6jyaa5438qyy985rqsd76kb8ibfy56g0"))))
+    (build-system gnu-build-system)
+    (synopsis "LARL(1) parser generator")
+    (description "Berkley yacc is a Look-Ahead LR (@dfn{LARL}) parser generator trying to be
+compatible with AT&T yacc as much as possible.")
+    (home-page "https://invisible-island.net/byacc/byacc.html")
+    (license license:public-domain)))