diff mbox series

[bug#42465,v2,08/10] gnu: Add python-flake8-bugbear.

Message ID 20200722120940.13811-8-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#42465,v2,01/10] gnu: python-typing-extension: Update to 3.7.4.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR July 22, 2020, 12:09 p.m. UTC
* gnu/packages/python-xyz.scm (python-flake8-bugbear): New variable.
---
 gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 26673c20c0..6be4c29976 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7909,6 +7909,34 @@  complexity of Python source code.")
        ("python-pyflakes" ,python-pyflakes-1.2)
        ("python-mccabe" ,python-mccabe)))))
 
+(define-public python-flake8-bugbear
+  (package
+    (name "python-flake8-bugbear")
+    (version "20.1.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "flake8-bugbear" version))
+       (sha256
+        (base32
+         "0qiihb242fygzyrfynq913ak7cdmx8mcac9c0zk3y5gv16qf80mx"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-hypothesis" ,python-hypothesis)
+       ("python-hypothesmith" ,python-hypothesmith)))
+    (propagated-inputs
+     `(("python-attrs" ,python-attrs)
+       ("python-flake8" ,python-flake8)))
+    (home-page "https://github.com/PyCQA/flake8-bugbear")
+    (synopsis
+      "A plugin for Flake8 finding likely bugs and design problems in your program")
+    (description
+     "A plugin for Flake8 finding likely bugs and design problems in your program.
+Contains warnings that don't belong in pyflakes and pycodestyle.  It is felt that
+these lints don't belong in the main Python tools as they are very opinionated and
+do not have a PEP or standard behind them.")
+    (license license:expat)))
+
 (define-public python-flake8-polyfill
   (package
     (name "python-flake8-polyfill")